Chinese support

simulation

#1

Hi,
I’m a foreigner playing on Chinese servers, I was trying AskMrRobot simulation yesterday but apparently the addon doesn’t support chinese region. Here is the error that I get :

The region, realm, or name could not be read from the provided import string.

Is there anything to do ?

Cheers,
M

Edit : Found a quick fix, just replace manually server name and region in the string, seems to work


#2

If you want to send me the string that didn’t work, I can give it a try – could be something with converting the different characters that didn’t work correctly.


#3

Thanks for the reply, here is the string :

$74;KR;亚雷戈斯;Plumee;TCW;1;2;120;44;11:150,6:98;3;.s1;19;;.s2;20;;.s3;21;2313212;.q3;158075s2b1558b3371b7b878;243s11b-4232b3201b227e5943;43s7b-3428b3201b227;5s12b-3428b3201b227e0;346s14b-3428b3201b19b208x154129;575s15b-4970b1542b3201b19b208x0;128s3b-3423b3199b635b27a286229a161a-6491a-11303;27s6b-3851b3187b226;7s9b-3428b3201b227;4487s13b-3518b3292b18x0;1612s1b-3280b3253b11b37b594a4302a16055a-22016a1659a-4618;1s10b-3895b286b2978b13x0;1s5b-3262b3249b38b595a8920a16055a-9027a-5538;13s8b-3882b271b2978b14x-422;23s16b-3263b3249b14e21;.inv;2459;4489;42693;15633;43802;11181;13120;4265;1085;1465;1254;159;47;2124;8718;0;0;0;18;1;63;3;62;0;0;27;773;266;5;415;2;753;1;0;5;0;10;1;939;52b1582b3201b227;1073;971b-3433b3209b17;268;0;0;13b-3256b3238b18;98b-3231b3214b224;48b-4970b1532b3214b224;1b-3438b3211b225e5943;763;3;166b-4966b1545b3197b226;114b-3423b3199b633b29a278617a7612a-22242;11b-3866b3201b227;3b-3423b3199b634b28a8911a575a6453a-11489;23b-3876b3214b224;7b-3433b3206b227;3b-3423b3199b635b27;156b-5406b1550b3192b226;8b-3468b3237b7;35b-3214b3214b16b208;133;266;0;0;159b-3438b3214b224;86;1072b-3533b3309b12;306b-3256b3241b199b147;781b-3577b3234b17;91b-3231b3214b224e0;488;46;135;7;0;0;0;0;0;144b-4968b1550b3192b18b323;87b-3548b3209b16b323;5b-3563b3224b339;10;1;409b-3563b3224b16b323x154127e20;56b-3633b3292;399;1154b-3267b3269b340;4b-5085b1481b3261b343;19b-3604b286b2978b13x0;36b-3277b3264b37b594a7040a3128a-11668a1659;1b-3880b3249b14;0b-3278b3264b13;1b-3277b3253b11b37b593a10013a-3132a-3931a2842a-10410;11b-3894b3264b13;1b-3277b3253b11b37b595a14627a4a-14501a4491a-4621;1b-3896b286b2978b13x-420;0b-3277b3264b13;1b-4759b1487b3256b16;1b-3277b3264b13;15b-3277b3264b13;4b-3277b3264b13;2b-3272b281b2975b16x422e1;78b-3232b3216b20;1b-4761b1500b3243b18;0b-3251b3233b18;14b-3226b3209b17e-21;13;11;88;32b-3296b3268b11b36b592a14631a10140a-17209a8477a-16039;103;1;1;20;292;36;168;115e0;236b-3897b3269b693;9;0;0;0;0;0;1$

I just had to replace manually KR;亚雷戈斯 by EU;RandomServerName to make it work. But it weirdly think I’m playing on KR region instead of CN. May be chinese characters are not supported ?


#4

Chinese characters should be supported, same with Korean characters.

Sometimes it will have the incorrect region if you e.g. copied UI or addon settings from someone else or an addon pack. If you go into your WTF folder, there is a file called config.WTF, open it with any text editor. Check the setting for “portal” and make sure it is set to CN, it will look like:

SET portal "KR"

Change “KR” to “CN” and it should get the correct region in your export strings. (You’ll need to do this with WoW closed, then start it up again.)


#5

Oh that is true ! I do not know how it happen to be set on KR, as I never went on KR servers and did my UI myself …
Anyway it is working perfectly now, thanks for your help :slight_smile: