Lua Error when importing


#1

Everything seems to work ok but sometimes this message comes up.

Message: Interface\AddOns\AskMrRobot\ui\Ui.lua:86: attempt to index local ‘color’ (a nil value)
Time: Thu Aug 23 04:04:11 2018
Count: 1
Stack: Interface\AddOns\AskMrRobot\ui\Ui.lua:86: attempt to index local ‘color’ (a nil value)
Interface\AddOns\AskMrRobot\ui\Ui.lua:86: in function CreateFont' Interface\AddOns\AskMrRobot\Gear.lua:314: in function <Interface\AddOns\AskMrRobot\Gear.lua:191> Interface\AddOns\AskMrRobot\Gear.lua:398: in function <Interface\AddOns\AskMrRobot\Gear.lua:395> (tail call): ? [C]: ? [string "safecall Dispatcher[3]"]:9: in function <[string "safecall Dispatcher[3]"]:5> (tail call): ? ...ace\AddOns\AskMrRobot\Libs\AceGUI-3.0\AceGUI-3.0.lua:314: in functionFire’
Interface\AddOns\AskMrRobot\ui\AmrUiTabGroup.lua:139: in function SelectTab' Interface\AddOns\AskMrRobot\Gear.lua:481: in function?’
Interface\AddOns\AskMrRobot\ui\Ui.lua:147: in function <Interface\AddOns\AskMrRobot\ui\Ui.lua:140>
(tail call): ?
[C]: ?
[string “safecall Dispatcher[3]”]:9: in function <[string “safecall Dispatcher[3]”]:5>
(tail call): ?
…ace\AddOns\AskMrRobot\Libs\AceGUI-3.0\AceGUI-3.0.lua:314: in function Fire' Interface\AddOns\AskMrRobot\ui\AmrUiTabGroup.lua:139: in functionSelectTab’
Interface\AddOns\AskMrRobot\ui\AmrUiTabGroup.lua:45: in function <Interface\AddOns\AskMrRobot\ui\AmrUiTabGroup.lua:42>

Locals:


#2

Looks like maybe I didn’t push the fix for this to curse/twitch… try updating the addon from our website directly.

Soon-ish I’m going to be working on some other updates to the addon and I’ll make sure everything gets updated with that new version.