LUA errors with v61


#1

After updating to v61 I get the following errors when logging in. Thanks.

Date: 2018-07-18 23:57:02
ID: 2
Error occured in: Global
Count: 1
Message: …AddOns\AskMrRobot\Libs\AceEvent-3.0\AceEvent-3.0.lua line 33:
Attempt to register unknown event “CLOSE_WORLD_MAP”
Debug:
(tail call): ?
(tail call): ?
[C]: RegisterEvent()
…AddOns\AskMrRobot\Libs\AceEvent-3.0\AceEvent-3.0.lua:33: OnUsed()
…ra_Broker_Guild_Friends\libs\CallbackHandler-1.0.lua:168: RegisterEvent()
HandyNotes_Argus\Core\Handler.lua:397:
HandyNotes_Argus\Core\Handler.lua:395
(tail call): ?
[C]: ?
[string “safecall Dispatcher[1]”]:9:
[string “safecall Dispatcher[1]”]:5
(tail call): ?
…AddOns\AskMrRobot\Libs\AceAddon-3.0\AceAddon-3.0.lua:558: EnableAddon()
…AddOns\AskMrRobot\Libs\AceAddon-3.0\AceAddon-3.0.lua:651:
…AddOns\AskMrRobot\Libs\AceAddon-3.0\AceAddon-3.0.lua:636
[C]: LoadAddOn()
…\FrameXML\UIParent.lua:445: UIParentLoadAddOn()
…\FrameXML\UIParent.lua:488: CombatLog_LoadUI()
…\FrameXML\UIParent.lua:1189:
…\FrameXML\UIParent.lua:1085
Locals:
None
AddOns:

Date: 2018-07-18 23:57:02
ID: 3
Error occured in: Global
Count: 1
Message: …AddOns\AskMrRobot\Libs\AceEvent-3.0\AceEvent-3.0.lua line 33:
Attempt to register unknown event “WORLD_MAP_UPDATE”
Debug:
(tail call): ?
(tail call): ?
[C]: RegisterEvent()
…AddOns\AskMrRobot\Libs\AceEvent-3.0\AceEvent-3.0.lua:33: OnUsed()
…ra_Broker_Guild_Friends\libs\CallbackHandler-1.0.lua:168: RegisterEvent()
…nterface\AddOns\HandyNotes_Directions\Directions.lua:285:
…nterface\AddOns\HandyNotes_Directions\Directions.lua:284
(tail call): ?
[C]: ?
[string “safecall Dispatcher[1]”]:9:
[string “safecall Dispatcher[1]”]:5
(tail call): ?
…AddOns\AskMrRobot\Libs\AceAddon-3.0\AceAddon-3.0.lua:558: EnableAddon()
…AddOns\AskMrRobot\Libs\AceAddon-3.0\AceAddon-3.0.lua:651:
…AddOns\AskMrRobot\Libs\AceAddon-3.0\AceAddon-3.0.lua:636
[C]: LoadAddOn()
…\FrameXML\UIParent.lua:445: UIParentLoadAddOn()
…\FrameXML\UIParent.lua:488: CombatLog_LoadUI()
…\FrameXML\UIParent.lua:1189:
…\FrameXML\UIParent.lua:1085
Locals:
None
AddOns:


#2

Similar to another user, this is not an error with our addon. We never use the event “CLOSE_WORLD_MAP” anywhere.

We use a shared library that many other addons use – sometimes the first one that loads shows up in the stack trace. I believe that HandyNotes_Argus might be the culprit here? Hard to say.