Monk < Level 110: Error: Object reference not set to an instance of an object


#1

For my Monk Best in Bags broke when Netherlight Crucible update happened

Tried updating armory, reimporting, changing characters, changing spec order, changing gear around no dice yet.

This is error I get from best in bags:

"Object reference not set to an instance of an object.

ticket number: ffaf5dac-5fc6-49cf-8734-1279143bb523"

Here is the addon export string I’ve been using
$52;US;Thorium Brotherhood;Yorek;The Ironsong Tribe;13;2;101;13:159,12:13,1:600,14:6,5:439;1;.s1;16;2123312;1277,8,8;1,1,1;,133004b767b1502b1809,;;.s2;17;0000000;;;;;.s3;18;1233133;;;;;.q1;87342s9;28837s10u529b58b467b10;6069s1b3057;6s7b0;7s15b0e4087;100s13b0;22s5b0e-3179;285s2b0;5505s11b0e4391;145s14;620s16y133004;128s3v100b-1798;3839s6v0b-1027;6s12v0b1025;13758s8b1667b111;.q2;87342s9;28837s10u529b58b467b10;6069s1b3057;6s7b0;7s15b0e4087;100s13b0;22s5b0e-3179;285s2b0;5505s11b0e4391;145s14;620s16y133004;128s3v100b-1798;3839s6v0b-1027;6s12v0b1025;13758s8b1667b111;.q3;87342s9;28837s10u529b58b467b10;6069s1b3057;6s7b0;7s15b0e4087;97s3b0;25s5b0e-3179;285s2b0;5505s12b0e4391;145s14;620s16y133004;3967s6v100b-2825;6s11v0b1025;38s8v-1b-1128;5888s13v1b0;.r;_;.inv;159;0;0;0;0;1047;323;1242;1;4;59;0;0;1;740;281;7;636;0;1025;0;0;0;2;231;0;218;61;219;116;344;232;962;62;272;1018;65;1266;591;186;384;251f69;356;2;2;0;0;169;265;1;4;7;5456;30;969;1549;1;1;938;0;9;0;0;0;0;0;0;0;0;3;0;0;0;0;0;0;0;0;0;23;0;0;51;0;0;44;1;43;274;244;5;121;1;2;1;1;499;2;16;2;3;3;1;8;1;4;1;306;1;2;9;2;1;2;4;1;3;626;0;3;0;0;165;235;1564;2553;565;0;0;0;0;0;0;0;0;1262;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;1827;775;6;1;1;4;1021;6;1;1;2844;3;6;1;5;9;768;4;45;79;518;460;26;11;53;31;3;7;13;4;4;1;780;1526;68;452;0;13;981;322;1351;3;0;1944;335;5215;233;2;140;1;1;1;390;4;21;1;8;5;281;3798;14247;0;551;458;0;0;1;0;0;1;1;8;1;16;43;2084;1;469;1344;69;1;2;5;2;2;4913;0;346;1041;4774;0;0;1351;545;1732;3379;2;1;1;3285;34;8595b545;361b-338;2b-183;80b178;162b-106;121;602;3;825;2;1;1;1;3;1;1;1;1;809;1;12;2;1;19;838;1;568;973b449;1;23;391;501;351;463;0;1;0;117;1441;126;325;235;0;16;0;272u529b-392b372b15;314b5;73u0b-405b385b10;613;4;6;26b10;525v91b3083;4v-4b0;17v8b0;13v-1b0;1084;212;1;35;174;0;1;5;2042;0;386;0;0;0;0;0;150v5b-2861;859;18b2825;5b0e4227;22b0;0b0;1533;202;1;3;313;1;2597;0;2037v1b-1798;28;0;1072;1;1;2;1;1;1;1;2;1;2756v0b-1027;10v-1b-103;5888v1b0;30;1;1;2;1321;1093v-1b1148;2500;8951;403;9;40$

The last time there was a problem it was because of my enchants.
Now I have also added a crafted legendary at 101


#2

I’m working on an update that should fix a few bugs like this. The new crucible stuff is having a little trouble with low-level characters who either do not have an artifact, or don’t have 3 relics socketed yet. The update should happen sometime today.


#3

Yes the new amr addon today fixed it. Thanks!


#4

Hello, for my Monk it seems to be still broken somehow.

Object reference not set to an instance of an object.

ticket number: 57363c35-00fb-4694-a3ca-84291767c667

Import string is:
$54;EU;Alleria;Shenzen;Die arkane Gesellschaft;13;1;107;13:61,15:127,12:37,8:726,14:224,2:800;3;.s1;16;0000000;;;;;.s2;17;;;;;;.s3;18;3211112;820,2,9,510;3,2,1,1;,141288b1381b1809b1812,;;.q1;124545s13u529;56s12u0b199b452b1;3372s15u0;5s2u0b-611;4s9u0;72s8u0;98s14u0b1446b1955;724s5b-1729b1679b16;3s1b-1705b1689b16;61s16y141288;307s6v102b-2744;4701s17;4217s7v-2b2723;1s10v0b0;2s3v0b0;282s11v0b0;.q3;124545s13u529;56s11u0b199b452b1;18s14u0b-47b47b111;3352s15u0;5s2u0;6s9u0;894s5b950b1679b16;3s1b-1705b1689b16;1s7b-1725b1709b16;2s6b-1721b1705b16;58s16y141288;294s8v100b-2641;4714s17;4218s10v0b2620;284s12v0b0;372s3v3b-2723;.r;_;.inv;2313;0;0;7;381;233;749;548;2;3;2214;0;212;0;286;57;1699;4104;7712;693;88;586;686;4;255;2771;46;59;337;2006;7532;48;2;508f42;839;422;128;450;1;1;2;19;126;97;14;135;0;176;6;1;189;2;278;1;2;2785;1196;1;1;611;504;2681;12103;1778;3;5;9;2;186;8;7;9;5;8;10;2081;171;7729;711;2;2959e15;242;1;4263;227u445;7241;193u0e4426;0u0e0;14u0;109u0;514;380;1618u6e0;154;322;988u-6;22;5;449u31;2170x76642;715;369u-11e0;0u2e0;548u-2;6u0;422;2126f346u0;66f346u0;226;251f361u0;373u28x44y0z-48;8;452u-2;1215;56x54e-13;85;2x7e0;1361f348u0;12f362u0e-5;62f347u0;7f355u0;2f344u0;5f360u0e383;42f357u0;0f356u0;31f356u0;3f346u0e-376;1f443u0x185y-185;2f344u0e374;263;1452;16u0;2u0;514;85;10;628u0;44u0;1u0x-13y-48e-371;5u0;0u0;120u0;685u14;18u0;59;3139;122;1;7;0;0;0;0;0;0;0;0;5;4;7;11;540;867;50;1;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;1771u-14b449;661;435;169b111;207b0;2b0;14;0;8b0;0;11;1;5b0;12;10;7;25b3x39175;8;5b-3;2b-519b519;10;107;39;0;796;94;498;18;527;59;154;5;180;386;76;1171;15;15b0;15;225;11;109;1;236;10;57;102;701;0;2;0;1;1;1;1;1;1;1;12;3;1340;548v106b104b1072;780;178;2;0;4;119;4;3;1;12;0;1503;14;0;2;0;2;0;2;0;1;1;154u38;4u0;158;0;1;0;0;1;0;0;125u0b-1546b463b111;0u0b-626b514b109;3u0b-606b497b113;0u0b-715b601b1;5u0b-504b505b111;8u0b-709b597b109;0u0b-570b460b1;8u0b-540b541b110;0u0b-690b575b5;0u0b-589b589b109;4u0b-632b522b109;0u0b-545b436b110;0u0b-570b459b1;5u0b-284b280b5;4u0b-165b164b111;0u0b-683b573b108;14u0b-330b220b2;4u0b-49b48b110;9u0b-582b468b4;0u0b-558b554b4;3u0b-424b420b5;1156;1621;56v-6b-38b41;198;1;217;1;1;1;90u0;5u0b-615;4u0;65u0;7u0;0u0;10u0;0u0;15u0;24u0b1436b1964;5u0b-2878;13u0;4u0;0u0;5u0;0u0;1u0b-3;0u0;21u0b927b1955;28u0;20u0;18;132u0b-3254b463b2;3;894v2b11;2925;2387v-2b103;3552;52v0b2620;2v0b0;0v0b0;1v0b0;1v0b0;1v0b0;0v0b0;0v0b0;1v0b0;0v0b0;0v0b0;23v0b0;0v0b0;573;9;1160;16v0b-2620;242;502v0b2613;752;151b-1565b1516b116;5b-1632b1b1631;0b-1633b2b1631;16v2b-2680;4507$


#5

To fix this problem you need to clear your web browser’s cache (not sure which element of the cache was the problem… most likely the cookies). Once I did that the error went away.


#6

That might work for some people – I just posted another update that fixes another issue. If you refresh the web page, then re-import from the addon and try again, it should resolve the issue for real this time!


#7

Refrehed everything. Now it works just fine :smiley:

Thanks a lot! You are great!

Kind regards


#8

What do u do ? Cause me its not working even if I clear my web browsers cache… Thx


#9

They updated the addon. That seemed to fix it for me. I also do the whole dance of open up your bank and artifact weapon and do export just in case something was out of date in the addon’s eyes as well as tell it to update my character from blizzard site


#10

Just to be clear, when all is working well, you should only need to manually open up your bank and all your artifact weapons and crucible once, the first time you use the addon. Then it automatically stays in sync afterwards, even when we update the addon.

Also, if you update from the Armory after importing from our addon, that will usually cause trouble, because the Armory does not have as much information as our addon – particularly crucible information now.


#11

Thanks for clarification.

Is there a way to work with Armory smoothly, a “best practice” if you will?
Do you recommend just trying to live without Armory?

The problems I experience which are most likely Armory related when using the built in “n” popup to select specialization change:

  1. Almost every time my artifact weapon doesn’t equip when switching to offspec, no matter how many times I export addon info to keep in sync with AMR.
  2. Also when switching to offspec, equipment I deleted like heirlooms are complained about days after I continued to export all specs to AMR to update them