Sim client install help - Mac OS


#21

Any news regarding the release without .net core bundled? Would love to go Premium but I need to be able to run the client. Thanks.


#22

Still on the list… not exactly sure when I will be able to test it all out. Working on a round of UI updates and making sure we are prepared for 7.3.


#23

Not using High Sierra, just plain old Sierra (10.12.6). Error on the very first step:

[Pauls-Mac-Pro:~] paulcons% /usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
Illegal variable name.


#24

Sheesh, seems I was running the wrong shell, fixed that but ended up with this:

Pauls-Mac-Pro:~ paulcons$ brew update
Already up-to-date.
Pauls-Mac-Pro:~ paulcons$ brew install --force openssl
Warning: openssl 1.0.2l is already installed, it’s just not linked.
You can use brew link openssl to link this version.
Pauls-Mac-Pro:~ paulcons$ mkdir -p /usr/local/lib
Pauls-Mac-Pro:~ paulcons$ ln -s /usr/local/opt/openssl/lib/libcrypto.1.0.0.dylib /usr/local/lib/
ln: /usr/local/lib//libcrypto.1.0.0.dylib: File exists
Pauls-Mac-Pro:~ paulcons$ ln -s /usr/local/opt/openssl/lib/libssl.1.0.0.dylib /usr/local/lib/
ln: /usr/local/lib//libssl.1.0.0.dylib: File exists
Pauls-Mac-Pro:~ paulcons$ openssl version
OpenSSL 0.9.8zh 14 Jan 2016
Pauls-Mac-Pro:~ paulcons$

No idea where this leaves me…

Gack, decided to see what might create smoke if I ran your client… it opened Terminal, started with a new window, spit a bunch of text at me, wanted my AMR logs, gave it that, there seemed no way to choose which option I wanted because the blinking cursor was buried in among the options. Managed to exit it, then re-ran it… hmmm now we are getting somewhere, it said to go the website and run a simulation! Clicked Simuation, set it for Gearing Strategy and low and behold, shit is happening. See updates on the website, see “50 setups of chunk 17 processed” think I’ve heard of that drug . Sheesh, now back to chunk 8… just hoping my 6 core 3.33GHz Zeon will make short order of this… going backwards, now on chunk 3!

Needless to say, ya need to have some stuff for before one even runs the brew installer. They made the same damn mistake, their top page jjust says “enter this in terminal.” WRONG… I dug deeper and it turns out the xcode CLT MUST be installed AND it has to run from a bash shell and mine defaulting to tcsh. The average Mac user will totally punt on this. EVEN if the enlist a local techie… they will get nowhere at all because the prerequsites are too buried.


#25

Ahh, do you want the newer version of ssl?

If the openssl is in your command path, it will always pick that one over your local unless you specifically run the newer version.

Destroy the link before you try to link that. either with rm or the safer way, unlink.

Remember to remove the link not the original file.


#26

Well I think the fruit deprecated openssl, so it’s only use for me is running the gearing strategy simulation… which after much sweat, it has completed.


#27

Bash is the best shell :wink:

/start shellwars


#28

Do somebody have an idea of how to set up the AMR Client running the new macOS High Sierra ?

I get this message trying to install Brew:

"A CA file has been bootstrapped using certificates from the SystemRoots
keychain. To add additional certificates (e.g. the certificates added in
the System keychain), place .pem files in
/usr/local/etc/openssl/certs

and run
/usr/local/opt/openssl/bin/c_rehash

This formula is keg-only, which means it was not symlinked into /usr/local,
because Apple has deprecated use of OpenSSL in favor of its own TLS and crypto libraries.

If you need to have this software first in your PATH run:
echo ‘export PATH="/usr/local/opt/openssl/bin:$PATH"’ >> ~/.bash_profile

For compilers to find this software you may need to set:
LDFLAGS: -L/usr/local/opt/openssl/lib
CPPFLAGS: -I/usr/local/opt/openssl/include"

I have no idea what to do …

Thx


#29

Hello Guys,

Still no solution for people using High Sierra (10.13) and want to use the simulator client ??

Do you will still support Mac User ?

Tried to contact people from AMR but nobody answer.

Thx


#30

In the near future we will be upgrading to a new version of .net core that should resolve the issue. We have some things to finish up for 7.3 first though – that upgrade will have to wait just a bit longer, sorry about that.


#31

Hi there,

is there an ETA for a new version of the macOS client? I keep getting a “Bus error: 10” since I upgraded to macOS High Sierra…

Thanks!


#32

I don’t have a specific ETA… but it’s on my list to upgrade to .net core 2.0 as soon as I’m able. Have a few other features and Antorus updates stacked up in front of that.


AMR Simulation client macOS X
#33

Hey!

Don’t mean to annoying but is the update for macOS High Sierra going to be ready any time soon? Do you have an estimate as to when?

I wanted to buy premium to get ready for T21 but as of now it’s pointless as I can’t run any simulations. Please help the mac users!


#34

We are working on the .net core 2.0 update right now actually. We will see if that makes it work for you.


#35

Thank you for working on it! :heart:


#36

We actually did the update, should be good to go now. I have made a new thread with updated Mac OS install instructions:

I’m going to close this thread – feel free to respond to the new thread with any other questions or issues you might have related to the client on Mac OS.


closed #37