Simulator Client Installation: Mac OS


#21

I don’t think it was ever fixed was it? Downloaded the newest client just now.


#22

Argh, its even worse then before, before I had a work-around that I’d have to use every now and then, now even that doesn’t work! macOS is doomed.


#23

I guess running chmod didn’t work… that’s the only change that was made. Is there such a thing as “running as administrator” type thing on Mac OS? Maybe the program itself doesn’t have permission to modify the permissions of another file or something? Not really sure.


#24

If that was the only change its weird because the file doesn’t show as a Unix executable, and previously changing it to one would fix it, now it doesn’t fix it.


#25

For now, you can run it with specific arguments:

amr worker xxx

Where xxx is the current version. I am out of town for the holidays so can’t look up current version right now. This will disable auto update and auto reconnect on connection errors, but should avoid the permission error until i have time to research it further.


#26

This does work, thank you, and thank you for the effort given to the macOS users, I know we are a fraction of a fraction of AMR users. Happy holidays.


#27

Regarding the BfA Client. How do I do this part to install the client

Run
Open a command prompt in the AskMrRobotClient folder

I know how to open Terminal. But how do I open a prompt inside of a specific folder.


#28

When you open a terminal, it is in a certain location in your file system. You can change the location with the cd command, e.g. cd another/folder

Change directory to your AskMrRobotClient folder, and run the dotnet amr.dll command.


#29

Will I have to do this each time I open the client?


#30

Yes, on Mac and Linux you need to always run it from a terminal window.

If you wish, you can make a script that you can run that starts it for you… perhaps someone with more mac or linux experience than me could post an example?