Add On doesn't work in Dragonflight

Hi I have been unable to get the addon to work with dragonflight. When I open it all that is there is a blank grey box with an X to close it up in the corner. It worked fine for me up until the prepatch to Dragonflight and since then I have been unable to use it. I have the latest version on Curse Forge. I am playing WoW on linux POP-os. I am not sure why that would cause a problem now though as it all worked fine prior to prepatch. Any help would be appreciated.

What version of the addon do you have? If you have v118 or later that shouldn’t happen. What you describe is exactly what would happen with a pre-10.0 version.

Sometimes people update their addons in the wrong folder if WoW is installed in multiple places, or perhaps you update beta instead of retail, etc.

Hey thanks for the help I discovered the problem, it seems I had WoW on 2 different hard drives from various things that I’ve done over time and WoW was loading from 1 place and addon updates for whatever reason were going to the other and so no matter how many times updated it still wouldnt work. Annoying but solved. Thanks again.