Best in Bags generates "Index was outside the bounds of the array" error

After some work, I’ve managed to get my protection warrior talents and gear imported successfully, but I’ve had several issues trying to successfully import my fury talents and gear to the website. To generate the updated export string for the addon I’ve activated each spec and equipped each gear set along with opening my bank. I’ve tried logging in and out. I’ve tried starting from different specs and gear sets. Finally I cleared the saved variables from my WTF folder to start clean. That was enough to get my protection spec working for both the addon and the website. Swapping to my fury spec I can see that it’s imported my talents, but clicking the Find Best in Bags button generates the indexing error, which also breaks the Send to Addon for the protection spec.

Reported error is:
Index was outside the bounds of the array.
Ticket Number: 762772aa5ebc497e90f4f52dbf921650
If you need further assistance, please contact technical support.

I should note this is using the latest 9.1 version of the addon.

If you press the “help” link next to the Best in Bags section header, follow the instructions to create a support snapshot and post the ID here. With that I can try your exact case and see what’s up.

Here’s the generated snapshot ID:

Thanks – I was able to reproduce the problem. We’ll have an update sometime later today that should fix it.

Thanks! I’m sure you’re very busy about now, so I appreciate the assistance and the speedy response.