"Error, Could not read the response"

Getting this error on website, when trying to access my toons.
Tried to empty cache, in browser.
Never seen it before, and now i can’t access the site.

Running MacOs and Safari

Having the exact same issue when I try to save custom stat weights.

Running Windows 10 and Chrome.

Are you getting the error when loading from the armory? Does it work if you import from the addon?

When i open the website, http://www.askmrrobot.com. / Gear
or http://www.askmrrobot.com. / contact
Forumsite goes fine to opens u can see.
Cant use it for looking at my toon, or use contact by that site
add-on works fine in game, ill copy the string, but thats it can’t paste it, cause site won’t open

1 Like

Hmm… I haven’t run into this issue before. Have you tried using a different browser to see if that works?

Yes i have tried Chrome, and it the same thing “Could not read response”

That is strange… any chance you are at work or something and they are blocking it? Sounds like you can’t connect to our servers.

I started getting this error yesterday, and so far everything I’ve tried has failed to fix it. I can’t log in. I can’t load an export string. I can’t even choose my character, region, or realm. Every time I try anything (other than logging in to the forum, obviously), I get the error message, “Could not read response.” I’ve tried Chrome, Firefox, and Opera (my default browser) with the same results. I’ve uninstalled/reinstalled the add-on. I’ve even uninstalled/reinstalled all three browsers to no effect. Has anyone had any success in dealing with this issue?

1 Like

What kind of error message is this… a small popup window, or does it redirect to an error page? Are you using any browser plugins e.g. https everywhere? That particular plugin causes problems sometimes.

You could also try clearing your local storage for askmrrobot.com… in Chrome you do that by opening Developer Tools, go to Application tab, Local Storage in the tree, select our domain. Select everything (click on top entry, scroll to bottom, shift-click on last entery), then press the delete button at the bottom. Reload the web page – see if that helps.

I figured it out now, for me its VPN "Hotspot Shield messing it up, when I’m turning vpn off, it works fine again.

That was actually going to be my next question!

Yeah, some VPNs mess with requests. A common thing is stripping out custom or unrecognized http headers. My guess is that you could leave the VPN on, but if you can set up a rule to tell it to not touch http requests/headers from the askmrrobot.com domain, it would work as well.

It’s a small pop-up window, and after more trial and error I’ve determined that it’s a VPN issue. I’m running SurfEasy, and once my VPN is disabled everything works fine. Unfortunately, I can determine no way to add exceptions so I’m left with having to disable it entirely if I want to use AMR.

I guess I’m a little confused by what these VPNs are doing that are causing the site to stop working… if anyone is interested in sending me some extra debugging information, maybe I could narrow it down.

If anyone is interested, try this: turn on your VPN that is causing the problem. Go to the home page http://www.askmrrobot.com. If using Chrome, as an example (similar in other browsers), open up the developer tools. Then refresh the page by shift-clicking on the refresh button (this bypasses your browser cache). Now look in the network tab of the developer tools, one request should be to api/wow/realms?version=44. Click on it to see details. If you want to direct message me the information shown in the Headers tab of the details (everything: general, response, and request headers), I can see what your VPN is doing and hopefully figure it out.

Same error, disconnected VPN “Norton Wifi Privacy” and it works.