Error: Object reference not set to an instance of an object

So it seems when I use a 225 Mad Paragon Boots, crit and mastery, in a sim combination I get the following error almost immediately. “Object reference not set to an instance of an object.” Removing it from my sim setup immediately allows the sim to start. I have not tried the same legendary in another slot or with different stat combo’s yet to help troubleshoot.

It seems that even if I lower the item level or use the waist slot version of it I still get the same error.

When you look at the gear for your simulation setup - is there an item in every slot? Specifically, is there a weapon equipped?

Yes. And actually the first time I discovered it was the Mad Paragon I actually simmed it without boots on because I deleted it out of that slot and then quickly hit the sim button to test. I have not crafted the Mad Paragon in either slot so I do not know if that matters for troubleshooting.

For giggles I just tried it with 210 Mad Paragon boots. Crit and Haste. It seems to be simming correctly. Just tried both 210 and 225 Mad Paragon boots with Crit in the first slot and Mastery in the second slot and it errored out both times. The 225 one gave this error. “The given key ‘171413b50b1006b1022b1079b1081b2228b4252’ was not present in the dictionary.”

Looks like it’s linked to the Mad Paragon in either slot with Crit and Mastery combination. There might be other combos but Crit Haste I’ve tried and it works, Crit Mastery I’ve tried and fails.

If you’d like I can try out every stat combo and give you links to each sim and the error codes.

Strange… there must be some specific setup in there that is causing an error somehow. I’ll see if we can get it to run in the debugger. It is very hard to track down the exact source of the error in a big batch sim sometimes. It’s not the mad paragon boots with crit/mastery specifically - I can run single sims with that. Must be that combined with something else.

If you could narrow it down to a much smaller batch simulation that exhibits the error, it makes it a lot easier to find the issue. 51,000 is quite a large, and it will be a while before I can tie up a machine for the long amount of time it would take to catch that error in the debugger.

Single Sim. Mad Paragon Boots 225. Crit/Mastery
Error: The given key ‘171413b50b1006b1022b1079b1081b2228b4252’ was not present in the dictionary.

I will start changing things one by one and see why.

I think that I might know the issue… somehow the bonus IDs on the legendary for the character you loaded are out of order, so it’s not matching up to the item cache used when doing simulations. We’ll fix that in the next update, probably tomorrow sometime.

Well leave it to me to find the most random bugs. Thanks for the help!