Issues with Client

When I attempt to run the Client, I receive the following error:

I tried following the steps from a different post,
by restarting my computer and leaving everything shut down overnight, but I am receiving the same results.

I am also trying to export data from Best in Bags but it won’t let me, I have tried restarting and even using a different browser altogether.

What error do you get when trying to export best in bags?

The spec is different depending on the Character, but the rest is the same.
Elemental could not be exported, Usually choosing that setup and re-optimizing will solve this problem.

Have you tried switching to your elemental spec and re-optimizing? That should regenerate the data required to do an export.

Yes, I have tried all 3 specs and different toons, the message is the same just the spec itself in the error changes.
My concern is more of the Client not working to be honest, as I cannot run simulations with different talents.

So in the example above, if you switch to elemental, go to the “configure” step, and change any setting… say change the Azerite threshold to something different, then press Find Best in Bags again, and then press Send to Addon – what error message do you get?

For the client, when do you get that error? Immediately upon starting the client? Or when you try to run a sim?

The spec “Elemental” can be different if I use a different spec or a different Character and class altogether.
The rest of the error however, remains the same.
For example, here it is on my Warlock.

The other error, I have since resolved by removing everything from my computer and then re-downloading and running the latest client. Sorry for any inconvenience as I should have thought to try that the first time.

That is strange… the act of optimizing should fill the cache that is used for the export feature and prevent that message from appearing.

Perhaps try logging out of the website, close your browser, then open it and log back in. Then go to Best in Bags, change any setting (like, gem quality or gem/enchant threshold), and run best in bags again. Then try exporting – does it still give the error?

I just don’t understand, it used to work, unfortunately, still no luck.

The fact that it is happening to any character you use is really strange… I’m not sure what would cause that. Could you post the addon export string for one of your characters, and let me know if you are using any custom settings? I can give it a try and see if I can reproduce the error.

I am importing from the armory.

oh… yeah Best in Bags doesn’t work very well when doing import from the armory. You really need to import from the addon so that we can see your inventory data (the armory can’t tell us what is in your bags and bank).

The armory only tells us your currently equipped gear. You can run a Gear Check on that (does azerite, gem, enchant optimization), and export that to the addon as well. But full Best in Bags requires… your bags!

Oh wow, I feel really bad for wasting all of your time on this then.
Thank you so much for all of your assistance.
Please feel free to close the thread.