Set equipping with the client

Hey guys…

My DK in particular has been tripping over AMR’s spec swapping. I’ve had problems ranging from a refusal to swap two rings (same two rings, opposite positions as defined by AMR), to having to click the spec change button in the client over and over to equip items one by one. I’ve tried deleting my saved item sets in the UI and letting AMR re-define them; I’ve tried turning off AMR’s auto-equip and using the in-game one, but that resolved nothing.

Currently, AMR is stripping my character down to nothing, and then equipping each item separately, to switch specs. This is scattering her gear throughout her bags, making it hard to keep track of.

Is there any way to… I don’t know… reboot that character? I’m not really sure where the problem lies.

Also having a problem, where playing as dps and switching back to healer to apply AP to weapon, its equipping healer gear on spec change even though the option to is unticked. then returning to dps spec, its leaving me in healing gear…

Never seen it remove gear before… what version of the addon are you using? The current version only does item swaps, doesn’t remove gear, so that even if your inventory is full it can swap. It’s actually a huge pain to deal with unique restricted items because the game gives no good way to even tell which ones conflict. So the gear swap process turns into a silly trial-and-error exercise. It’s on my list to investigate if there is some better way to do it that I just haven’t found yet.

Also, you can reset all addon settings to default (which disables auto-swapping gear) by typing in the chat window:

/amr reset

I’m using v50. It’s the only character doing that at the moment. My main, a druid with her four specs, generally does okay… certainly she doesn’t do the whole strip-poker routine.

It was weird because it was almost like it learned from what I did… because the first problem was with those two rings that wouldn’t switch, and I used my “naked” gear set to force it.

Unfortunately it’s hard to test because I can’t load anyone’s characters but my own…

If I could see exactly what gear/spec you’re trying to change from and to, I could try to reason out where it is getting stuck.

e.g. if the problem happens when you swap from frost to unholy spec, if you could:

  1. Go in-game, equip your frost gear.
  2. Then, swap to unholy spec and manually equip the gear it refuses to swap to when switching away from your frost spec.
  3. Go to the Export tab in our addon, copy the text here.

Then I can see the two sets of gear it’s trying to swap between, maybe figure it out.

Of course, replace frost/unholy spec with the two specs you’re trying to swap between.

The export remains the same, correct? So I can post the export, then just note what issues occur and between what specs? Like…

(Export here)

Blood -> Unholy - what happens
Blood -> Frost - what happens
Frost -> Unholy - what happens

Yeah that should work – I mainly just need to get an export string from you that shows exactly which two specs/sets of gear it’s trying to swap between, see if I can figure out why it doesn’t like it.

50;US;Silvermoon;Phzibylana;Six Minutes To Release;5;1;110;9:740,15:700,3:800,13:715,14:725,12:716;3;.s1;1;2112333;272,1,1,1,1,1,1,1,1,1,1,1,1,1,1,3,1042,28,122,1,1,144;4,4,4,3,3,4,3,3,3,1,1,1,1,1,1,1,1,1,4,1,1,1;140818b1467b3443b3528,140823b1477b3515b3528,140816b1477b3336b3514;.s2;2;3322232;108,1,1,1,2,1,1,2,2,1,2,1,1,966,1,1,240,28,268;3,3,3,3,3,3,3,3,1,1,1,1,1,3,1,1,1,1,1;141267b1517b1825b3528,133122b1621b1738b1792b1809,143700b1527b1824b3336;.s3;3;3231323;149,1,1,1,1,1,2,1,1,104,1,1,1,1,1,852,214,28,268;1,1,1,1,1,1,3,3,3,3,1,3,3,3,3,3,1,1,1;140043b1482b1825b3527,143694b1522b1824b3336,133138b1615b1793b1809;.q1;121280s7b42b1480b1872b134;7122s16b-2812x140818y5z-7e3847;4041s8b2743b71;1747s13b-2927b919b1872b134;1s11b-3486b1480b303b1512;3153s14b-1860b349b1701;3256s12;278s9b-2050b1859b178;2s6b-3474b1427b1976b85;3s3b-2056b2042b14;17s2b-2051b1859b178;13s5b-2037b2038b13;3490s15b-2036b316b1528b108x-10599;2356s10b-1912b293b1512;485s1b-1690b50b1639b238;.q2;121280s7b42b1480b1872b134;7012s16b-2811x141267y-8145z10578e3370;1s17;4150s8b2742b71;1748s12b-3488b1480b303b1512;5833s11b-1815b302b1512;766s13b-1869b341b1635b85;88s9b-2051b1859b178;2s6b-3474b1427b1976b85;3s3b-2056b2042b14;17s2b-2051b1859b178;7s10b-2042b2042b14;6s5b-2051b2038b13;622s14b-3486b1435b1859b130;2868s15b-1974b316b1528b108x-13483;2841s1b-1797b50b1639b238;.q3;121280s7b42b1480b1872b134;7123s16b-2810x140043y3651z-10556e3368;4040s8b2741b71;1748s12b-3488b1480b303b1512;5833s11b-1815b302b1512;766s13b-1869b341b1635b85;88s9b-2051b1859b178;2s6b-3474b1427b1976b85;3s3b-2056b2042b14;17s2b-2051b1859b178;7s10b-2042b2042b14;6s5b-2051b2038b13;622s14b-3486b1435b1859b130;2868s15b-1974b316b1528b108x-2921;2841s1b-1797b50b1639b238;.r;_;.inv;765;1682;2;2176;32280;1;2245;189;3;1140;2623;3;46;1291;1131;1;1;1;411;1;6996;1458;7532;1;1;2902;6201;551;14509;1256;5348;16329;177;1307;1817;734;570;3232;3;1449;2580;3159;20;313;1;1;3853b717x141267y-8145z10578e3370;12;10;39;49b-1x-2882y5z-7e477;111;3296;383;45;1953b-113b919b1872b134;3154b-2051b349b1701;767;241b-2055b2042b14;615;706b-145b2;2b-3b4;1b-5b4;1b-3b3;2b-1b2;1b-5b5;106;16;390;211;2;167;28;167;39b-1914b2042b14;85b-2056b2042b14;32;428;254;47;5107b-1996b293b1512;147;1;2;2;337b-1695b72b1814b46;100;224

I’m making swaps using /amr equip # macros.

Unholy or Frost -> Blood - Character is stripped to her chestpiece, then the new set is equipped one at a time.
Unholy <-> Frost - Character stripped to head, neck, shoulders, chest, and waist, then new items equipped one at a time.
Blood -> Unholy - Character stripped to head, neck, shoulders, chest, waist, and top ring, then new items equipped one at a time.
Blood -> Frost - Character stripped to head, neck, shoulders, chest, waist, and top ring, then it just stops, claiming something is missing. Have to open the addon and use the button there to resume the process.

The screenshot below is Unholy -> Blood. The new set has begun equipping with the first trinket slot, although the model is obviously slow to update to the changes.

Wish I knew how to video it.