"There was an error reading the provided addon data"

Hi All,

Been using AMR for many years.

Today, I’ve had an odd problem where the website fails to read my exported command.

It happened on my monk on Fri, which automatically resolved itself over the weekend - no idea how.

And now its happening on my shaman.

For reference, the command is below. Help please.


86;US;Frostmourne;Franksama;Jurisdiction;3;1;120;87;13:175,15:10,12:46,1:175,6:174;3;.s1;28;1111132;0.23.3_1.5.2_2.35.1_3.27.3;.s2;29;;;.s3;30;3312113;0.32.2_1.24.1_2.20.1_3.19.3;.q1;157891s3b1607b3168b11b1479a278697a1710a-508a7875a-23796;62s1b-4658b3168b11b1478a14719a1732a-14249a2419a-4621;122s2b-4620b3288b1b1383;1309s7b-6276b1577b3169b220b1507b3;6s10b-4894b3164b219b1510b47b16b1;3158s11b-4962b3169b219b1510b1;2901s8b-4954b3224b1730;215s13b-4879b3149b17b1712;915s5b-4953b3213b11b1718a15851a7775a-7705a-11300a-4621;2423s12b-4892b3174b17e6108;221s15b-3331b4808;81s14b-4793b3299b12;3341s6b-4758b1512b3234b1575b28b73b19b34b63b1;9s17b-6538b1511b3234b1601b1b125b3;651s16b-4964b3234b1575b27b127b1;1650s9b-1713b1712b25b38b1;.q3;1QYZ7yxHWwzbALy1H8FotGwZUfz5Zfidi-10836a-3917a16;24s2b-4862b3288b1b1383;4473s12b-4699b3169b219b1510b1;729s9b-4879b3149b339b1369b19b65b1b34;2172s8b-5051b3224b1730;215s13b-4879b3149b17b1712;3559s15b-5043b4808;94s14b-4793b3297b14b1062;3252s1b-4303b3218b11b1600b2b117a23322a-9634a-9777a12132a-16043;85s17b-6464b1511b3234b1601b1b125b3;50s5b-4959b3218b11b1576b26b116a14735a1913a-12743a713a-4618;601s16b-4952b3234b1575b27b127b1;143s10b-5014b3284b16b1b1609b101b3;2s7b-5014b3284b17b1609b101b3;368s6b-5029b3299b1626b25b18b60b63b1;651s11b-5092b3299b36b1691b3;.ess;4_4;5_2;6_3;12_4;14_1;15_1;16_1;17_3;19_3;20_1;22_1;23_3;24_1;27_3;28_3;32_2;35_1;36_1;.inv;2459;4489;33824;4808;64980;27082;1087;1463;1254;159;10907;64;63;2249;0;0;1QYZ7yxHWwzbALy1H8FotGwZUfz5Zfidi-508a7875a-23796;30b-4658b3168b11b1478a14741a-3331a-11404a4610a-4616;2b-4657b3179b1479;30b-4658b3168b11b1478a14719a1732a-14249a2419a-4621;2b-4657b3168b11b1479a13688a1031a-11760a1659a-4618;96b-4628b3149b1720a14719;40b-4899b3178b18b1710b50b15b1;62b-4977b3183b18b1710;226;0;331b-4931b3201b20b1052e5962;674b-5815b1577b3169b220b1507b3;6b-4894b3164b219b1510b47b16b1;7b-4962b3169b219b1510b1;262b-4944b3207b7e0;208;0;0;0;1551b-3244b3241b1067;1130b-4248b3182b223b848e146;488;361b-4218b3149b339b1390b1;207;2058b-4909b3179b16b1;917b-3241b3213b11b1718;225;208;543b-5018x167556y1192z-1055p5865p455;183;477;1;1;5;161b16b3284b13;419;200b-3187b3174b17e0;302b-3316b3299b12;25;3;1;158;377;344;964;963v120b1555;355;25;126b-4811b3244b1574b29b126b1;0b-6476b1512b3234b1575b28b73b19b34b63b1;21b-5037b3244b1601b2b124;782b-5026b3299b17b1609b101b32b33b1;28b-5102b3309b17b1609b103b42b21b1;5b-5077b3284b17b1609b103b1;12b-5024b3294b17b1609b101b3;757b-5029b3288b11b36b1683a18a38422a-53029a23666a-23796;29;8;1;64;0;406;1;132;36;28b-1702b1712b25b38b1

I suggest cycling through your available specs, as in activate each one, then open your bank.
After that try the export again and see if that clears the problem up.

That import string got garbled somehow… could you try disabling all of your other addons, then export again? Let me know if that works.

If it does work, perhaps you could help me narrow down which other addon is causing the issue – I’m curious as to what could make that happen.

Hi Cluey, I’ve cycled through all my specs, but no fix.

Hi Yellowfive, I’ve disabled all addons, and left only AMR. Still bugged.

For more context, all this only started last Friday. My monk still works perfectly fine.

Weird, I just cleared my interface WTF folder and its now giving me problems on both Shaman and Monk.

That is really strange… the only thing that I can think is there are some really weird item strings on your system that our code doesn’t know how to interpret.

The only way that I know to debug this further is if you were to send me your AskMrRobot.lua file from your _retail_\WTF\Account\[your account name]\SavedVariables folder. Perhaps with that data I can figure out why it is having a hard time. You can click on my name at the top of this post to send a direct message to me with the file.

Hey Yellowfive, I cant seem to find the button to private message you in your profile.

Could you point me in the right direction?

I sent you a direct message that you should be able to reply to.