Addon import not reflected properly


#1

Since 7.2 when I import data from the addon the web UI doesn’t show the correct iLvl. If I use the armory import it works and shows the correct information. Here is the string:

$50;US;Trollbane;Truthbringer;Calamity;5;1;110;13:783,15:800,12:800,1:772,14:772,4:764;2;.s1;19;3212122;965,377;1,1;141260b1522b1824b3336,141260b1517b1825b3528;.s2;20;2132121;1120,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,208,35,179,1,1,87;1,4,4,4,4,3,4,3,3,4,1,1,1,1,1,1,1,1,4,1,1,1;,;.s3;21;1133222;40,1,1,1,1,3,2,1,1,1,1,1,296,1,1,1,765,157,372;1,3,3,3,3,3,1,3,3,3,3,1,1,1,1,1,1,1,1;,;.q1;128823s16b735x141260y15z-15;5312s5b842b1760b236;227s9b-3533b1512b1785b76;2708s7b-1602b1718b1;370s14b-1988b266b1529b172;1617s6b-1957b1785b136;8s11b-1901b252b1513e5428;270s13b-1825b1824b237;1561s12b-2086b1850b177e0;8s8b-2027b1849b108;3s10b-1972b341b1701;1300s2b-2017b1839b237;2294s3b-2026b1789b80e455;2743s1b-1744b32b1824b45;520s15b-2096b1860b236e-449;.q2;128866s17b736x140845y417z2430;1s16;5268s5b841b1760b236;227s9b-3533b1512b1785b76;2708s7b-1602b1718b1;370s14b-1988b266b1529b172;1617s6b-1957b1785b136;8s11b-1901b252b1513e5428;270s13b-1825b1824b237;1544s10b-2091b331b1631e17;17s12b-1957b1850b177e-17;8s8b-2027b1849b108;3371s1b-1633b1718b1;226s3b-1983b1789b80e455;3263s15b-1939b1860b236e-449;1s2b-2091b326b1720b44;.q3;120978s16b737x141260y-3768z3;11474s12b1074b1719;1683s5b-1953b1760b236;227s9b-3533b1512b1785b76;2708s7b-1602b1718b1;370s14b-1988b266b1529b172;1617s6b-1957b1785b136;8s11b-1901b252b1513e5428;270s13b-1825b1824b237;1544s10b-2091b331b1631e17;25s8b-1957b1849b108;1303s2b-1947b1839b237;2294s3b-2026b1789b80e438;2743s1b-1744b32b1824b45;520s15b-2096b1860b236e-449;.r;_;.inv;2771;5;125;23;433;501;3090;964;3026;1;1;38;20;84;1;1;50;1;2;2;35;1;1;1;1;3165;1;1858;1;1;806;46;5389;1;1;1;1;1;1122;6611;3869;1;1;0;1;1;1;3648;977;672;3657;2;89;8976;247;230;0;163;1;1;2;1;16514;2397;1;2;78;283;2249;1;1;0;1;2;27966;6858;52;7;1;557;0;0;0;0;867;685;2016;1;0;2;324;1916;918;983;1067;450;2056b737x141260y-3768z3;135v110b960b115;167b-300b301b1600;2638;185;4;1;1;1;2;1;2;1;1;1;1;1;1;0;0;3;0;0;0;0;0;313;0;1;0;1;0;1;1;1;0;0;2;3405;651;211b-2813b74b15;3472;1;6;9;1;4;239b1122b1644;9b-1644b1719;1118;6;1;12;1;3;14;23b-2013b1820b76;2b-1916b229b1802;48;1;74;380b-2021b167b134b1666;5b-1967b1829b137;40b-1951b1815b137;1b-1977b177b1758;0b-1930b1834b96;3b-1930b224b1611;20b-2733b893b177b1758;20b-1885b1789b237;4b-2071b225b86;40b-311b1834b96;54b-2828b893b177b1758;58b-2828b923b1809b58;127b-1887b1829b75;12b-1919b235b86;3b-276b1799b237;0b-2051b1889b117;1b-2036b235b86;3b-1772b1486b1885b116;3b-2006b205b1609;1104b-1864b207b1749;1021;75b-1931b177b1758;0b-1900b195b1609;4b-1824b1825b95;0b-1890b1986b45;15b-2066b1829b96;228b-1930b1834b74;2b-1913b230b1609;39b-1525b1718b1;30b-1719b1644x-7275e5428;58b-1644b1644;325b-1938b210b1801;31b-2011b210b1801;67b-1986b1795b76;3b-1921b235b86;580;109b-341b335;142b-335b341b1701;7b-3472b1430b341b1701e6;598;92b-2007b1829b96;3b-1930b1834b96;0b-1905b297b1512;1b-1839b177b1758;31b-1920b1824b138;3b-1977b177b1758;1b-1930b1834b96;0b-1935b177b1758;129b-1975b1922;5b-1917b1874b43;8b-1882b230b1609;87b-1834b2026b45;468;195b-2066b167b1800;8b-1967b1830b60;174;2;18;23;372;0;202b-1930b1976b85;105b-2046b326b5b1631x0e455;13b-1972b341b1701;2b-2037b331b1528b178x0e-455;537;36b-3474b1432b336b1658x0;123;47;465;0;90b-1969b1839b237;128;1;88b-2106b341b1697;247b-2018b326b1649;807;1;989b-1930b1996b45;11b-2041b1996b45;2b-2041b1804b77;16b-1886b1886b115;157b-3488b1472b2016b45;502b-2031b165b101b1720b45;1567;34;97b-2036b287b1513;4b-1815b1872b134;9b-1981b1789b237;39;1;2;319b-1931b55b1831b46;16b-1902b32b1824b45;4b-1931b64b1822b46;15b-1902b94b42b1720b45e455;0b-1901b109b27b1720b45;6b-1901b8b1848b45;482b-2091b326b1720b44$


#2

This may help, as it has for me when addon copy/paste failed to bring over my artifact level and/or relics, which lowered my avg iLevel by a lot.

Before opening the adfon, pop open character (“c” by default), and a then open your artifact (shift right click I believe).

THEN open the addon and copy-paste to the website. Should be all better.

FWIW, pretty sure they are aware of it at AMR, but prioritizing tomb gearing strats and such over fixing this one. Can’t speak for them, just guessing.


#3

What you mention @crosbyg isn’t really a bug – the only way to get your artifact information is to pop open the UI that shows your artifact. Once you do that at least once after installing our addon, everything stays in sync. But you need to open it up for each artifact weapon at least once the first time you use it on a character.

We could automatically force the artifact window open… but I feel that’s irritating and a bad game experience. There is a popup message the first time you use the addon that mentions this as well.


#4

hmmm, thx for clarifying!

I know in the past, this used to happen sporadically even after the initial install, at least for me. Maybe it got resolved or was specific to my setup.

thanks


#5

FYI this problem persists. For me almost every time I switch specs and import from the addon, the non-active specs have the weapon reset back to ilvl 750. This is a huge annoyance as I constantly run 2 specs (normally dps and either heals or tanking). I have having to see that it didn’t import correctly and having to redo it after reopening my weapon every single time. It should at the very least retain the previously stored ilvl.


#6

I’m not quite sure why this happens to a small percentage of people… for most people it remembers the last relics it saw with no problems.

With 7.3 we’re going to have to update everything anyway to deal with the netherlight crucible. We’ll look at it in more detail then.