Docker for the SIM client - Unraid


#1

Kinda new to the client/sim portion of AMR. But I have Unraid server that i was trying to get the Global network running on so I can contribute to the Cause.

I wanted to run the client in a docker so that way the client would run dynamically on unraid. but I dont see any working dockers out there. Just posting to see if anyone has any input on this. As ive tried using https://hub.docker.com/r/acidweb/askmrrobot But it just fails on run.


#2

Sorry – I haven’t used docker much, so don’t have anything for it. Just getting it to work in linux was a big step for me!


#3

For what it’s worth, you only need to install one thing to get the client working: the latest available version of the .net core runtime, described on the simulator client download page.

When I spin up lots of linux servers to crank out simulations in the cloud, I use a simple script to install .net core when each node starts up. Microsoft has the process documented:

See the footnote, you only need dotnet-runtime-2.2.1 not aspnetcore-runtime-2.2.1

And of course use the picker for your flavor of linux.

Not sure if that’s enough information for someone to set up docker or not.


#4

Thanks for the Reply! Yeah if i cant Figure it out soonish I may just end up booting a Ubuntu VM up on it solely for that. The only downside Is i think I have to dedicate cores and memory to that vm rather then it running dynamically from docker. But eh, ill keep poking around for a bit.


#5

I ran into the same issue and decided to build a new docker image. I’ve also open sourced the Dockerfile so it will be easier for anyone to update in the future.

New image with instructions is here:
https://hub.docker.com/r/gaffneyc/askmrrobot


#6

Awesome, so I have a unraid server and ive installed the docker image. but im not sure how to enter the my username and password from this, When i boot the docker the log shows that its trying to connect but then crashes. if i run the docker it just shows a console where I cant enter anything.


#7

The first thing you’ll need to do is to create a volume that will store the credentials, run the image with an interactive shell so you can input them, then you should be able to start up the simulator. I just fixed a typo in the instructions so it’s possible that was the problem.

docker pull gaffneyc/askmrrobot
docker volume create amr-settings
docker run --rm -ti -v amr-settings:/AskMrRobotClient gaffneyc/askmrrobot

You should be able to enter your credentials at that point. Either exit through the menu or ctrl-c to kill it.

To run the image in the background you’ll need to make sure to attach the settings volume.
docker run --rm -d -v amr-settings:/AskMrRobotClient/ gaffneyc/askmrrobot


#8

Sorry for the late reply, yeah I didn’t even notice the typo. All is good now! thank you for you time to put this together!