In game mr robot failure to open to get string


#1

Mr Robot is failing to open in-game just on my main character. I have uninstalled and reinstalled. When i right click it removes my weapon and a ring. When I left click it prevents me from being able to open my bags and character screen. This does not happen on any other characters… I am at a loss as to what to do next. Have restarted computer and game several times after reinstalling Mr Robot…


#2

Are you getting any lua errors?

An easy way to catch addon errors when you have an issue is to install these two other addons meant for trapping errors:

https://www.curseforge.com/wow/addons/bug-grabber
https://www.curseforge.com/wow/addons/bugsack

These are very small addons, the first catches any errors, and the second gives you a minimap button for displaying them.

Could you try installing those addons, then do what is giving you trouble in our addon. If an error happens, copy the error message and paste it here.


#3

3x AskMrRobot\Gear.lua:1171: attempt to index field ‘?’ (a nil value)
AskMrRobot\Gear.lua:1171: in function <AskMrRobot\Gear.lua:1032>
AskMrRobot\Gear.lua:949: in function <AskMrRobot\Gear.lua:912>
AskMrRobot\Gear.lua:975: in function handler' AskMrRobot\Core.lua:661: in function <AskMrRobot\Core.lua:655> [C]: ? ...nts\libs\CallbackHandler-1.0\CallbackHandler-1.0-7.lua:29: in function <...nts\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:25> ...nts\libs\CallbackHandler-1.0\CallbackHandler-1.0-7.lua:64: in functionFire’
…\AngryAssignments\libs\AceEvent-3.0\AceEvent-3.0-4.lua:120: in function <…\AngryAssignments\libs\AceEvent-3.0\AceEvent-3.0.lua:119>


#4

What specific action causes this error? i.e. what steps would I take in-game to reproduce it?


#5

left clicking on the Mr Robot icon on my mini map causes my keys to lock up for opening character
screen © and bags(B) ((using bagon))Edit to add it locks up my keyboard. No keys work after left clicking the Mr Robot Icon… right clicking the Mr Robot icon swaps out my weapon. It was doing weapon and ring now just does weapon.


#6

Have you tried disabling all other addons to rule out a conflict? Also, have you tried deleting all of the addon settings as well? Using the Twitch App can help with that – otherwise you can manually delete the AskMrRobot.lua and AskMrRobot.lua.bak file found in your WTF folder under your user account folder.


#7

I have not yet started on disabling all of the addons to check if there is a conflict but i did go into my WTF folder/acct name/Character name/SavedVariables and there is no AskMrRobot.lua.bak or lua file even tho the addon is installed. Am I looking in the wrong place?


#8

It would be under your [account name]\SavedVariables folder. We don’t create a separate file for each character, they are all stored in a single file for your user account.