Lua Error During Import


#1

Today, with 8.0.1 dropping, while using v59 I’m getting the following Lua Error.

Searching the forums now to see if anyone else is facing this with the pre-patch being released.

Regards,

FelixFTW

Message: Interface\AddOns\AskMrRobot\Gear.lua:16: attempt to index local ‘item2’ (a number value)
Time: Tue Jul 17 22:16:42 2018
Count: 1
Stack: Interface\AddOns\AskMrRobot\Gear.lua:16: attempt to index local ‘item2’ (a number value)
Interface\AddOns\AskMrRobot\Gear.lua:16: in function <Interface\AddOns\AskMrRobot\Gear.lua:9>
Interface\AddOns\AskMrRobot\Gear.lua:89: in function <Interface\AddOns\AskMrRobot\Gear.lua:83>
Interface\AddOns\AskMrRobot\Gear.lua:116: in function FindMatchingItem' Interface\AddOns\AskMrRobot\Gear.lua:269: in function <Interface\AddOns\AskMrRobot\Gear.lua:193> Interface\AddOns\AskMrRobot\Gear.lua:419: in function <Interface\AddOns\AskMrRobot\Gear.lua:416> (tail call): ? [C]: ? [string "safecall Dispatcher[3]"]:9: in function <[string "safecall Dispatcher[3]"]:5> (tail call): ? Interface\AddOns\Ace3\AceGUI-3.0\AceGUI-3.0.lua:314: in functionFire’
Interface\AddOns\AskMrRobot\ui\AmrUiTabGroup.lua:140: in function SelectTab' Interface\AddOns\AskMrRobot\Gear.lua:521: in functionRefreshGearTab’
Interface\AddOns\AskMrRobot\Import.lua:17: in function <Interface\AddOns\AskMrRobot\Import.lua:9>
(tail call): ?
[C]: ?
[string “safecall Dispatcher[4]”]:9: in function <[string “safecall Dispatcher[4]”]:5>
(tail call): ?
Interface\AddOns\Ace3\AceGUI-3.0\AceGUI-3.0.lua:314: in function `Fire’
Interface\AddOns\AskMrRobot\ui\AmrUiButton.lua:25: in function <Interface\AddOns\AskMrRobot\ui\AmrUiButton.lua:22>

Locals:


#2

Do you think that you could send me your saved variables, and let me know the realm/name of the character you got the error on? Instructions on where to get your saved variables and how to post them (because it can be a large-ish file):


#3

Since I also had this error, I’ll send you my own saved variables and hopefully they’ll help:
http://www.mediafire.com/?hg4fim104g3b8 the character name is Lucìphel-Dalaran.


#4

Hopefully this will get you what you need… This after freshly re-installing the addon. I can also duplicate the problem with zero other running addons.

-FelixFTW

From-
C:\Program Files (x86)\World of Warcraft\WTF\Account\SavedVariables\AskMrRobot.lua

https://pastebin.com/Z4Jha9nL


#5

Thanks for the info – I have reproduced this error and will have a fix posted soon in the next addon version. Use this thread for more updates or if you still have issues after the update goes out:


#6