New gear sets being created without tabard or shirt


#1

In pre-v65 AMR, gear sets were created with both the tabard and shirt slots marked as “Ignore This Slot” in the Equipment Manager. Now, in v65-and-beyond AMR, the “Ignore This Slot” attribute is no longer being set on the tabard and shirt slots, which results in those slots being left empty in the stored Equipment Manager gear set, which then results in those slots becoming un-equipped when switching to the spec tied to that gear set.


#2

The addon ignores shirt/tabard when it creates equipment sets… not sure why it isn’t for you. When I look at all my sets created by the addon, they have those slots marked as ignored though.


#3

Scenario:

  1. Use AMR to create gear set(s) for a character.
  2. In Equipment Manager, associate each gear set with its corresponding spec (using the “Settings” cogwheel on each gear set). For example, click the “Settings” cogwheel on the Arms gear set, then choose the “Arms” radio button to associate the Arms gear set with the Arms spec.
  3. In the WoW Specializations dialog, switch to a spec that has had its AMR-generated gear set associated with a WoW spec.
  4. Result: tabard and shirt slots are cleared. Also, it’s evident that the tabard and shirt slots are not marked as “Ignore This Slot”.

I’m assuming that the “Ignore This Slot” attribute is being respected within the AMR addon, but perhaps not being saved as part of the Equipment Manager gear set attributes, or some such. Thus, when using Equipment Manager from within the native WoW functions, there is no “Ignore This Slot” attribute stored for those two slots… or some such. Again, simply surmising there.


#4

I’m definitely setting to ignore those slots when creating AMR gear sets. In the addon where it creates/updates the gear sets:

    -- ignore shirt and tabard
    C_EquipmentSet.IgnoreSlotForSave(INVSLOT_BODY) -- shirt
    C_EquipmentSet.IgnoreSlotForSave(INVSLOT_TABARD)

I will have to look at why that isn’t working… used to, haven’t changed the code in a while…


#5

OK I think that I figured out the problem… the first time that you create/update an equipment set via code after a person reloads their UI or logs in on a character… ignoring slots just doesn’t work. If you wait a second and call the same code a second time to recreate the same exact set… then it works.

This is why I hate changing anything in the addon… heh.