2 (then 1) of 3 gear specs not equipping

Hi All,

My assassin spec isn’t loading the gear exported from the website and its reporting the wrong ilvl for the artifact weps.

I get the messages below,

It started with Assassin and outlaw not loading properly, but Sub did. However, after manually equipping the BiB Outlaw gear, then switched specs back and forth between sub, then back to outlaw, outlaw’s gearing worked. Unfortunately, the same hasn’t been the case for Assassin.

The website/addon is reporting the incorrect ilvl for all the artifact weapons, but only the assassin’s are creating an issue, by not getting equipped, stopping the remaining gear from also being assigned to their slots.

Below is my export string,

$63;US;Fenris;Calucian;End Game Theory;6;1;112;3;13:1,15:3,12:1,8:2,2:2;1;.s1;25;1111311;.s2;26;2131323;.s3;27;1122322;.q1;121241s1v112b1697b115;7628s17;1s16b-1071b739b4b1x153421y-20571z3868p1495p246p52p16q-325q242q1802;89s14;359s13v-10b-821;4316s11b812b350b1702;6990s6;6633s12b-2006b257b1558b237;5503s3b-2102b219b1837b101;5315s2b-2153b3456b1b2;1219s15v9b-159;1s8v0b0;26s10v0b-4736b4736;19s9v0b0;562s5b-1a280710a-12116a-4616;2040s7b-3081b3233;.q2;128872s16b742b738b0b3x137302y-3539z8301p1481p345p1510q-1866q325q14;87s14;280s11v107b-715;79s13v-5b-104;5234s17;3843s1v9b1130;2229s6;6633s12b-272b257b1558b237;5503s3b-2102b219b1837b101;5315s2b-2153b3456b1b2;1219s15v0b-159;1s8v0b0;26s10v0b-4736b4736;19s9v0b0;562s5b-1a280710a-12116a-4616;2040s7b-3081b3233;.q3;121027s11v110b1764b44b4;7449s16b-1069b737y133059p1494p247p52p16;3s17;480s14;359s13v-8b-816;9077s1v9b1130;1351s9b1587b4x-17256;878s6;6633s12b-1863b257b1558b237;5503s3b-2102b219b1837b101;5315s2b-2153b3456b1b2;1219s15v0b-159;1s8v0b0;26s10v0b-4736b4736;581s5b-1a280710a-12116a-4616;2040s7b-3081b3233;.inv;5060;1307;581;959;16375;7122;3817;5482;5303;759;1;11379;50974;7;2;6;450;976;49;1;1;946;1707;214;97;1206;727;1877;715;125;11;233;1962;2;1;1;423;3;84;82v110b1764b44b4;454v-2b-1045;323b-102;335;1971;1;1;1;2;1;1;1;1;1;1;3;313;1;0;1;0;0;0;0;5;3438;491;103b78b737y133059p1494p247p52p16;396b-738b738b0b3x4243y-3539z8301p-328p345p1510q-1866q325q14;367v-1b-715;758;2175;711;1559b716b242b1802;1900;203;6;2;1;1;231;1325;284v4b-1734;382;98;427;444b1587b4x-26261;65;20;2;64;295;1413;47;2133;672;2800b-1883b241b1785b46;3887;422;975;35;1;473;1115;557;175;1;4266v1b-1877b3099;171b-3344b3333b166a273150$


ps, I should make mention that I’ve tried the earlier recommended troubleshooting techniques, such as reinstalling the addon, disabling other addons, deleting the lua file and recreating the profiles, going through the motions of opening the bank/void storage, swapping specs, equipping the gear, shift-click on the weps.

I just tried your import string and it’s working how I’d expect it to.

Just to be clear, you’re talking about what happens when you press a different spec button, the ones just to the right of the Import from Addon button when looking at the Best in Bags screen?

Do you have any items locked in?
What order do you have the specs optimising in?

It behaves the same by either clicking on the button within the addon window to the right and when right-clicking on the minimap button.

No items are locked. I’m not even sure what this is. I use AMR fairly simply, as I’m a casual player, looking for gear suggestions.

I follow the addon’s exporting instructions,
click Export from the addon window,
ctrl-c the highlighted text,
alt-tab to the website,
paste into the import box,
click to BiB,
click “find BiB”,
click “send to addon”,
click game
click gear
click import
ctrl-v into box
click import

cycle through the specs confirming everything matches the website.

My order of specs is Assassin, Outlaw, Sub.

I do want to note that the addon has worked in the past like a dream, even after patch, but I was still pretty low level gear. It was once I started acquiring stuff from the expansion.

Also, its just the Assassin spec that’s doing this. I haven’t been able to try changing weps because I don’t have replacement daggers just yet. The other specs are working (swapping). Albeit, neglected.

Thanks for your help, thus far.

I’ve purchased a couple of ilvl 204 daggers from the AH (greens). They worked. All the specs are now functioning normally. Albeit, the website isn’t seeing 1 of the 2 daggers for sub, and is still recommending the artifacts. Also, I can no longer select the artifacts daggers as an option for the assassin spec. Outlaw does offer either using the daggers or the artifact weps.

I’m happy, albeit feeling a bit silly for having to purchase green daggers on the AH. Fortunately, not very expensive and I now have piece of mind.

I’ll post my current export string for comparison’s sake.

$63;US;Fenris;Calucian;End Game Theory;6;1;113;4;13:1,15:3,12:1,8:9,2:18;1;.s1;25;1111311;.s2;26;2131323;.s3;27;1122322;.q1;121241s1v112b1697b115;8077s13v-10b-1148;17939s12b858b257b1558b237;5503s3b-2102b219b1837b101;1714s6v10b1147;3601s2b-3298b3454b1b2;144s14v0b-148b1;143s11v1b-12;932s15v-2b0;1s8v0b0;45s9v0b0;6s10v2b0;176s17v-1b-3081b3101;3s16v0b-3102b3102;377s5b-21a280710a-12116a-4616;2040s7b-3081b3233;.q2;129318s13v102b664;9077s1v9b1130;8862s12b-272b257b1558b237;5503s3b-2102b219b1837b101;1714s6v1b1147;3601s2b-3298b3454b1b2;144s14v0b-148b1;143s11v1b-12;932s15v-2b0;1s8v0b0;45s9v0b0;6s10v2b0;179s17v-1b-3082b3102;377s5b-21a280710a-12116a-4616;2040s7b-3081b3233;27s16b-3249b3249;.q3;121027s11v110b1764b44b4;7449s16b-1069b737y133059;3s17;839s13v-8b-816;9077s1v9b1130;1351s9b1587b4x-17256;13014s3b-1913b219b1837b101;1714s6v1b1147;3601s2b-3298b3454b1b2;144s14v0b-148b1;143s12v1b-12;932s15v-2b0;1s8v0b0;51s10v2b0;556s5b-1a280710a-12116a-4616;2040s7b-3081b3233;.inv;5060;1307;581;959;16375;7122;3817;10785;759;1;11379;50974;7;1;1;6;450;976;49;1;1;946;1707;214;97;1206;727;1877;715;125;11;233;1962;2;1;1;423;3;84;82v110b1764b44b4;1112;1971;1;1;1;2;1;1;1;1;1;1;3;1;312;1;0;1;0;0;0;0;5;3219;147;72;491;103b-1069b737y133059;394b-739b739b4b1x20362y-20571z3868;2b-743b738b0b3x584y-3539z8301p1481p345p1510q-1866q325q14;87;280v-3b-715;2933;1462b708b350b1702;2911;3;3;2;1;1;231;1325;284v4b-1734;382;98;427;444b1587b4x-26261;65;20;2;359;432;981;47;749;1384;672;2800b-1883b241b1785b46;3887;422;975;35;1;223;250;1114;1;557;175;1;129v2b1213;4294v-2b-4747b4736;14b-3324b3333b166a273150;2634b-3273b3249$

I’ll see if I can get a spare minute to take a look… there were some rough spots transitioning from artifacts back to “regular” weapons, since artifacts are super-special snowflakes.

I am having a similar problem when changing specialization.

I am a priest and when i change spec all my gear loads for the right spec but my weapon slot remains blank.

I am using a staff.

I get a message :
AskMrRobot: An item in your saved gear set could not be equipped.
AskMrRobot: Try opening your bank and running this command again.

I disabled the add on and my gear swapped fine in equipment manager with the add on uninstalled. As soon as i re-installed i had the same problem.