Add-on bug / reloading a character on the website / missing item from comparisons / etc

  1. In add-on version 64, the Combat Logs section has yet to show me all of the available difficulties for Uldir, at first it shows me all but Normal (where normal would be is just empty) but at some point it only shows Mythic. I tried deleting the add-on and in-game settings (via Twitch) and re-installed but no change.
  2. On the website, could you add back a way to reload a character from the Armory without having to type it in manually? A reload icon beside the trash icon would be great.
  3. Can you add back a way to “favorite” characters so they’re at the top of the list? I often load up guildies but they don’t need to be high on the list for later use.
  4. The WQ trinket Berserker’s Juju seems to be missing from the comparison list although when I equpped it, the location in the list seemed to be about what I expected so I would think it’s actually available on the site, just maybe not visible.
  5. Is the neck iLvl going to be picked up automatically at some point or is that not technically possible? I keep forgetting to change it when I’m simming.

(do you have a public list of known/current issues that we can see? The project site directs us to submit bugs via the forum but it’s hard to tell what’s active vs inactive or even finding specific bugs in terms of whether they’ve been reported or not)

I’m not sure why all the checkboxes don’t show up for some people… when I updated it with Uldir I explicitly tested and fixed that issue – there are some really weird bugs that happen with some of the UI changes blizzard made in BfA. I am able to get them to display and function correctly every time with version 64 though… haven’t figured out what causes different behavior for some users yet.

I see Berserker’s Juju in the list… we do have it flagged for tanks only.

Can you give me an example of a character where the heart of azeroth does not load with the correct ilvl? Works for my character.

We can probably work in an armory reload button somewhere that doesn’t involve typing it in.

I’m willing to test a version with diagnostic code if it’ll help, let me know. Alternatively, if you have code you want me to add to particular files let me know that as well, I’m comfortable doing that.

Ah - the tank flag is incorrect, then, my hunter got that Juju trinket from a WQ so I assumed that “missing health” related to boss health since the tooltip gives no indication either way.

Sure, just picked a random top 10 parser from WL, seems it’s picking up the +15 tiers from the rep but not the i2 bonus for each Azerite level for that person as well. Try Emlis from Khaz’garoth, the neck shows as 325.

Juju trinket is definitely based on your own missing health. We implemented it in beta when nobody had it though – I just got one so I’ll test how much haste it gives depending on your health. We didn’t know if it would just be bad for non-tanks or not. Seems it gives an OK amount of haste even at full health. Not going to be a good trinket… but usable.

The armory must not be sending over the same bonus IDs on the neck as I’m able to get from the game… I’ll look into it. Really our in-game addon is a much better way to load characters when possible.

I don’t even know what to test for the checkboxes not showing up… the code is not complicated, and I can’t seem to reproduce the problem. Do the checkboxes on the Options tab work fine?

For what it’s worth when I reloaded my toon after raid tonight it either picked up the actual iLvl or when I tried to change it manually earlier the change stuck… if you made changes they likely worked. I’m often not in-game when I’m simming which is why I generally use the armory load.

Okay, I’ll do some poking around myself then to see if I can figure out what’s going on. Unlikely to come up with anything useful but worth a shot.

I think blizzard added some caching of some kind… it seems really sensitive to when you position a UI element. e.g. if you position it, then show it, vs. show it, then position it… sometimes it will or won’t update properly. Haven’t fully figured it out yet.

I couldn’t figure out the code issue, the last thing I hadn’t tried was screen resolution… I think that’s the problem, when I run at 1920x1080 it works fine, my native 2560x1440 has the issue so that probably explains why only some people are experiencing it. Not sure what to do about it, though, except that I wasn’t having this issue prior to the DX12 change to Windowed(Fullscreen) in BfA. I’m going to poke around a bit more still.

The only other thing I’ve been able to determine is that it does tend to display properly if I select the Combat Logs tab, exit the UI via the X (doesn’t work the same if I use the minimap button to toggle), then click the minimap button to toggle it open, that combination seems to reliably display all 4 difficulties.

From a fresh load (/reload or logging into a toon), clicking the minimap icon to display the UI and changing to the Combat Logs tab will have a missing Normal checkbox and label, going to the Options tab and back to Combat Logs does seem to display it properly, going to Options and back to Combat Logs has a missing Normal label and the checkbox is non-interactive and is located above the Mythic checkbox line.

Best guess, there’s something going on with the combination of screen resolution and how the tab is loaded/refreshed depending on whether you get it via the minimap button or from another tab as well as whether the X or the minimap button was used to close it the previous time in terms of saving some settings.

I’ve run out of things to try on my end, let me know if you need anything else.

Thanks for trying it out – I’ll see if I can reproduce it by playing around with different resolutions.

I’ll also poke around some of the addon UI forums and see if anyone else is running into similar issues.

For what it’s worth, I just noticed that the add-on display clears up if I move it… never even thought to try that before today. Might just require a refresh or something after the page loads?