Addon Mini Map Icon too far in

(Since I’m new I can only embed the one picture, but I have another shot of the icon also within the borders of the elvui mini map. Can provide if needed)

I just noticed this today. I have the latest version from Curse Forge. Happens with or with out Elvui. I have totally removed the addon and the saved variables from the WTF folder, and reinstalled. Still get the same thing. Any way I can pull it out a bit to line up with the map instead of having it in the map? Thanks!

Until the AskMrRobot Addon is updated with the newest version of LibDBIcon, you can install the Lib as a standalone Addon.

1 Like

This unfortunately had no affect on the placement of the mini map button.

This doesn’t happen to me… is there some kind of setting that would mess with it? It shows up on the edge of my minimap using the default UI.

This is the behavior with many minimap addons that scale the ‘amount’ of map you see to be larger than the default minimap size. Whatever the addon is that you are using to change your minimap is the reason for that positioning.

This is with all addons turned off (not my first rodeo :wink: ), then reloaded UI. Is there a scaling variable in the default UI somewhere that might have been messed with?

I can’t even move/drag my icon at all. It’s currently sitting right on top of my covenant symbol. :unamused:

Strange… I’m not sure what would be causing the issue for just some people and not others… unfortunately addons are really difficult to fix when I can’t cause the problem on my own machine and mess with the code until it is working.

There is a UI scale setting in the Graphics options in-game, but I could not cause the issue using that either.

When I get a chance I’ll see if there are any updates to the minimap icon library, but it’s pretty stable and rarely changes.

So after removing my WTF folder and all my addons. I reinstalled the addon and it seems to be working now. No clue as to why. My best guess is there was a setting that an addon was mucking with that caused it to misbehave. /shrug

Glad that worked! I’m going to update the addon soon with a new version of the icon library… may or may not help in some cases like this.

1 Like