AMR-Best in Bags seems to struggle with 2 pieces of identical gear used in different sets

When I have 2 pieces of identical azerite gear used in different sets with different traits the manager seems to get confused and tries to use only one of the pieces for both sets and asks me to reforge traits depending on the set leaving the other sitting in my bags with the correct traits already chosen. Even if I try to differentiate them on the site and lock them specific to each set it ignores that in the game client and just equips the same piece in both sets.

I haven’t figured out why this happens to some people… I tried to recreate the issue – I have two of the exact same item with different azerite traits in two of my sets, and the addon reliably swaps between them when I press the green button in the addon to equip my set.

Maybe there’s some specific sequence of events that causes it to happen? What steps are you using to equip your optimized set of gear in-game?

I have this same problem on my Disc priest. I have the bloodbough shoulders and I have two of them at the same iLvL. One set of traits is used for disc and another set of traits is used for Shadow. I have to manually check every time I swap to make sure I have the correct set on because It will usually just default to whatever I’m wearing already.

My usual order of operations is this:

  1. Export the text string from the ingame addon to the website.
  2. Click on "Find best in bags (I already have the setup settings for each build in there)
  3. Make sure that I don’t have any locks or exclusions that I don’t want
  4. Click “export to addon” and copy the text string
  5. In game Select Gear/import and paste the text string.
  6. Since AMR builds/updates character sets I select the first setup in the list and click “activate spec and equip gear”. check as I am going through each setup for any Azerite changes that it requests or missing enchants.
  7. Do this for all of the setups that I have imported for that toon.

I have noticed that (or atleast I think this is true… I need to play with it more) that If I go to the reforger and wipe the traits for both pieces of gear that are having issues and then redo the export/import process that it sorts itself out… sort of… Here is what I mean (this is whatt I did lastnight that worked on my druid).

I noticed that it had a conflict with one of my Azerite Shoulder pcs. I have 2 identiacl ilvl/named shoulders and AMR wanted to use one for Balance and the other for Feral M+ with 2 completely different trait sets. but kept equiping/suggesting azerite changes on only one while ignoreing the other in my bags with the specified azerite traits to change to already chosen on them. I went to the reforger and wiped both pieces of traits and reexported/imported. which of course presented me with a full set of choices to make on that gear (not just chane one trait). I set it up for boomy as requested and then clicked the Feral activate spec/equip gear button and it again tried to use the shoulders that I had just set up for boomy. at that point I re-exported/imported yet again and this time it picked the correct (still blank) shoulders from my bags for the Feral setup and left my boomy shoulders alone.

My conclusion (on a very limited data set) at this point is that it is not simultaneously assigning items seperate values in a single export, but if you follow its recommendations for one setup and then re-export it figures it out.

When you click the button to equip one of your sets of gear, it scans your inventory for items that match the setup you imported from the website. So when it gets to an azerite item, it will scan your bags for one with the same id, bonus ids, and azerite traits selected. It will always go with the one that most closely matches what the optimizer chose.

Only thing that I can think is that somehow it isn’t able to see which azerite traits you have selected on an item in some cases… I’ll play around with it and see if I can somehow reproduce it.

One thing you could try that might narrow down the issue… if you make any changes to your azerite traits (clear them at the reforger, or choose a new trait on an item), immediately after doing so, open up the AMR addon and make the Export tab visible. This will force the addon to scan your inventory and ensure that it has read your latest azerite changes. Then try equipping your gear sets again via the “activate spec and equip gear” button – does it work then?

No. I tried that. If I have one set of shoulders equipped with my healing traits, and then use the addon to switch to my shadow spec with the other shoulders that have dps traits, it will just sit on what I have equipped and not switch. When the call to the new set is made, it doesn’t appear to me to be looking at Azerite traits. It seems to only be looking at the name and ilvl of the item. The import is fine because the shopping list shows the correct Azerite traits. But the in game addon doesn’t equip the proper item going from one to the other. Does that narrow it down?

No… it definitely looks at azerite traits. The same code that finds which item to display in the addon gear tab is used to find the item to equip when you press the button. And it definitely works in some cases – I have a couple characters with multiple of the same azerite items and I’ve tried several scenarios, they all work.

Must be something else that is causing it, otherwise it would never get it right… will have to keep poking at it I guess.

I gathered up a bunch of test cases, made a few code tweaks to deal with potential edge cases… hopefully this will be fixed for everyone in the next addon update. That update will probably happen at the same time as our 8.1 update next week.

1 Like