AMR doesn't load for one character only

Tried multiple isolation troubleshooting steps:

  • /amr reset – doesn’t help, even after reload
  • Deleted WTF folder
  • Deleted Cache Folder
  • Deleted AskMrRobot addon folder, reloaded version 6. It still shows for other characters, not the one.
  • Disabled all addons except AMR, closed game, reopened, no AMR.
    What else can I try? Character is level 61 human rogue. Just yesterday the addon was showing.
    /amr displays no text in chat.
    AskMrRobot is not appearing in game menu > AddOns. Enabled a couple other addons and they do appear in the Addons menu.

If it doesn’t appear in the game’s addon list, then it just isn’t there. Usually this happens if you e.g. put it in the retail folder instead of the classic folder.

@yellowfive, it is in the game’s addons, and appears for enabling/disabling when choosing addons in the character selection screen, prior to entering the game. Once INSIDE the game, when the addon enabled, it does not appear in the in-game menu addons list, but only for this one character. For other characters, it works normally.

That’s strange… I’m not sure what would cause that… only thing I can think of is some kind of error preventing the addon from loading, but even then… I’d think it would still show up in that menu…

Unless there’s some kind of lua error to capture, unfortunately it’s a bit tough for me to troubleshoot further. I can try doing some searching to see if similar things have happened for people with other addons.

Solved it, well, at least got past it. Deleted the AskMrRobotClassic.lua file in SavedVariables, and the issue went away. Wish I had thought to save the file rather than delete it.

Glad that worked! Though I’m not quite sure why it worked… I guess something strange got saved into the settings file that was causing an issue.