Amr.exe just quits

I used to use amr.exe just fine… but today when I launched amr.exe it says checking for the latest version and I get the command prompt back.
So I downloaded the latest version extracted the zip to its folder and re-run it, same result… amr.exe starts and quits 5 seconds later…

I re-downloaded the .net mentioned at the download page and reinstalled it. did not help.
what to check?
Thanks, -t

Sometimes this happens if it can’t establish any kind of connection to the server… it fails right away before it can do anything else. Do you have anything that would be blocking certain domains?

Thank you very much – today it’s working better… It actually updated itself and it’s waiting for work.
Hopefully it will go beyond “queued” sometime soon…

I did have an issue with one of the servers that tracks the client state last night, but it seems to be working again. When you submit a simulation, it should go right to your client within a couple seconds.

I’m now getting this, too. When I tried to start AMR earlier, it didn’t appear for a few seconds so I thought I might have single clicked the icon instead of double-clicking. When I double-clicked, two AMR windows appeared. I closed one, while it was doing something (… bad move, I know), and the other one said AMR was already running. I closed it and tried to start again, I got a window telling me in red text there was an error trying to start the client and contact support.

I cleared my queue via the website, got the same message. I redownloaded the client and now I’m getting this behavior: window pops up, I see it is checking for the latest client but then closes rapidly. In Process Explorer (Win10), I do not have amr.exe running, nor is any process with a company name similar to AMR.

Maybe a reboot would help but I’m not going to do that for a few days still. Did want to report the behavior though. Let me know if there’s anything you’d like me monitor or capture in the meantime.

Unfortunately these kinds of issues can be tough to diagnose…

I am working on a round of tweaks to the simulator client that may avoid the issue in the future, but don’t have an ETA on when that will be completed.

In the short term I’ll see if I can get it to more reliably trap errors early in the startup process.

Hi guys!
I find a solution.

  1. download
  2. open in winrar
  3. run amr.exe from archive
  4. enjoy

ps after work winrar will ask you to modify archive with new files - agree

That is really strange that it would work from inside the archive but not on your own file system… would have to think about why that would matter in any way…

this program desperately needs a “debug mode” that we can run and find out where it’s crashing and why. Today it’s back at crashing… I tried it a dozen times. same result…