Amr.exe stops working

I’m using version 446 of the client on Windows 10, and this issue has been happening for a few builds now.

When I am performing a simulation, around the 25% completion mark, I get an error message saying that “amr.exe has stopped working” with a Cancel button. There is nothing else.

I have to cancel, which closes amr.exe, reload it, and refresh my simulation in progress.

At first, I thought it might be Windows’ power settings shutting down for inactivity, but a few things:

  • I change the power settings to always on for hard drive, monitor, and the issue continues
  • amr.exe is still running, therefore Windows should assume that there is activity and not shut down anyway
  • Windows does shut down on my scheduled one hour of inactivity –– after amr.exe stops working if I do not click Cancel, ie: I do nothing for an hour anyway

Suggestions, anyone?

Okay, not sure if this helps, but I am using a Ryzen 7 on liquid cooling, overclocked to 3.975GHz, and running amr.exe in max performance with global network further locked up my entire system after restarting the simulation and getting to 44%.

I have changed amr.exe to normal and global network off to see if it completes.

If you see a dialog like that, it means that some kind of unhandled error has happened… that should be pretty rare, there is a lot of error handling in the client.

You said that you are able to restart amr.exe and it resumes your simulation, and eventually finishes it?

In your AskMrRobotClient folder, there should be a subfolder called version446. In that folder is a folder called logs – is there anything in there? It is possible that it logged the error.

The logs folder is empty.

And after I restarted the client, it not only failed again at 44%, it completely locked up Windows. I could not even Ctrl-Alt-Del to pull up Task Manager. I had to press the reboot button on my tower.

amr.exe only recovered after that, and only because I knocked down the CPU load from max to normal.

I did find a .dmp file in another location –– C:\Users\myname\AppData\Local\CrashDumps. Therein contains amr.exe.2488.dmp but I cannot upload that here due to file extension restrictions.

I’m assuming you are running a gearing strategy or custom batch simulation? Could you link me to the report for one of the simulations that is crashing? I can try it on one of my machines to make sure there isn’t something wacky with that setup e.g. causing an infinite loop somewhere.


Thanks, I’ll see if I can get one of my machines free to run that same setup over the weekend.

Any news about this? I haven’t turned max performance or global sharing back on because I don’t want to go through crashes and lockups.

Whoops, sorry I forgot to follow up. I ran it on one of my systems with no problem… I can try it one more time with the debugger running, see if it encounters anything unusual. That can take a while though.

Would you like the code string from the addon? The more information you have, the better? For that matter, I could export my DXDiag profile of my hardware.

I have it running… could take a while – I had a problem with the test machine I was using, seems to be sorted out now though. I notice that the report you linked is for the f’harg script – a user created that boss script for us, and it’s possible that there could be an issue with the script that gets it stuck – I haven’t reviewed that particular tank script in as much detail as the others. If that’s the case, hopefully this test would reveal that.

So the test in the debugger just finished running… saw no anomalies, ran to completion in about 3 hours (debugger slows it down a lot, and it’s an old machine, so that seems like a reasonable run time).

I’m a bit stumped as to what might be causing your client to crash… but as far as I can tell it’s not the code/simulation itself.

Hmm. Is there more info I can provide that might be useful? DXDiag, maybe? Could it be a Ryzen issue?

I am unfortunately not much of a hardware guy… so I wouldn’t be able to do much with a DXDiag.

I have a ryzen that I use to crank out simulations on a regular basis… so I don’t think it’s a general issue with ryzen.

In theory the simulation that I ran was an exact duplicate of the report that you linked… same settings and everything. I suppose it’s possible that something wasn’t exactly the same… I’m assuming you ran a gearing strategy simulation with no special settings?

Yep. I did select the usual things like augment rune, food, flask, but I didn’t select things like the mythic settings or whatnot.

You mentioned that simulation was user submitted. I could try a default one instead. Do you have a suggestion for a tank?

For single-target raid boss, try Fallen Avatar (just make sure to up the Mythic+ Level until it is threatening… a good rule of thumb is do a single sim on your character, and up it until you are around 40-50% death chance, then use that to make your gearing strategy).

For AoE tanking including raid bosses with lots of adds, the M+ script is good.