AMR giving impossible netherlight suggestions

I’ve noticed this on multiple characters… AMR’s auto gem/enchant is suggesting I pick a certain trait for #2, but then the trait for #3 that it suggests is the one that was opposite (and therefore locked). What’s going wrong?

Example for my Havoc Demon Hunter:
Relic: 880 Performance Enhancing Curio
Suggested Traits: Master of Shadows => Sharpened Glaives (Unattainable).

I would need your addon export (the string you copy from the addon to our website). Every relic has random traits on it, so I need to see your specific gear to try it out.

Here’s an example for my up-and-coming Enhancement Shaman. The second Relic Trait (Steadfast Conviction - Season 7) it says to choose Chaotic Darkness => Crashing Hammer, but that’s not possible. Refractive Shell is the one that connects to Crashing Hammer.

$57;US;Ner’zhul;Ahstrapez;Non Venia;8;2;110;9:800,15:3,3:808,13:735,14:785,12:350;2;.s1;28;;;;;;.s2;29;3212111;899,1,1,1,1,1,1,1,1,1,1,1,1,1,1,17,421,37,205,1,1,1,91;1,1,1,1,1,1,4,4,4,4,4,4,4,4,4,1,1,1,4,1,1,77,1;143683b1547b3337b3394,154102b3159b3528b3583,137365b1517b1726b3528;1,1739,40,3,-189,-688,8,1,0,1,0,1,0/2,826,40,-4,-862,-4,684,1,0,0,0,0,0/3,146,32,4,-863,681,-686,1,0,0,0,0,0;.s3;30;;;;;;.q2;128819s16b745x143683y10419z-16737;54s17;4760s2b797b185b1609;570s13b-2733b889b333b1702;55s5b-1980b1789b58;39s10b-1857b287b1512;45s8b-1804b276b16b1704;66s15b-2011b209b82b1720;2695s6b-69b171;254s14b-2108b204b1610;1708s11b-1794b1852b134;8681s7b-2046b2046b44;21s12b-2085b1849b236;4995s9b-2095b209b1650b293;3s1b-2157b231b1825b101;4s3b-2157b209b127b1720b101;.r;_;.inv;4941;1426;21580;9628;1779;151;972;3675;163;11232f132;6694;1;880;5643;2158;160;551;9421;5088;15657f348u491;28f357u0;7f468u0;2f480u0;1f356u0;2f354u0;2f380u0;1f471u0;1f345u0;1f463u0;7231;69;0;7840;4303b1527b1810b57;3352;4271b-2648x141256z-4283;920v110b2881;7v0b0;4102;264b-3024b924b297b1704;10b-3488b1497b288b1703;31b-1991b287b1512;74b-1794b1852b134;2335;100b-1976b175b1609;98;1440;435;349b-3294b565b930b287b1512;208;134;155;125b47b3;3b-5b4;4b-4b4;81;16;7;31;2;350;395;707;311;47;680;1453;65;607;2819b-2780b1037b166b1720b46;279;4;317;3379v0b54;1;1507b-2156b211b1845b101;1b-2157b221b1835b101;2b-2157b238b1818b101;2b-2157b234b1822b101;4084$

When I run it, it says to pick chaotic darkness and gathering of the maelstrom. I wonder if something is cached for you…

One way to ensure the cache gets cleared is to import new data for that character – change around an item in-game and export again, see if that refreshes it.

Hmm… I was trying that thinking that could be the case, but it didn’t seem to fix it. shrug Guess I’ll have to check it next time I come across it.

You could also change a setting or filter on the site that would invalidate the cache, e.g. changing the allowed gem quality from epic to rare. Save it, should re-optimize and clear out any cache. Then you can change it back. Might also do the trick.

No, sir. Just tried that. I’ve tried swapping gear, reloading the UI, logging out and back in, and changed filters on AMR to attempt to reset it. This time on my Priest… My 875 Vision of An’she is showing Master of Shadows => Say Your Prayers, but it’s not a possible combination. I would say it was perhaps my PC, but I was just at my mom’s a few hours ago and hers did the same thing to me. :-/

Oh well, I’ll just assume the third slot is the goal, and choose accordingly. Thank you for trying to help. :slight_smile: