AMR Import error "The data string is not in the correct format"

I decided to see if AMR could handle a level 61 Windwalker Monk I am levelling up as I have enchants and Heirlooms to put on him.

I can import string from addon into website and run best in bags successfully
But when I export the string back and try to import it into the addon in game I get
"The data string is not in the correct format" (this is the data string your web site gave me)

$51;US;Thorium Brotherhood;Yorek;The Ironsong Tribe;13;2;61;5:247,1:277;3;.s3;18;1233000;;;;.q3;51962s9f80t213;1s8f71t214;13354s12t215;23039s10t216e4740;1209s6t217c1;32683s1b582t218;6s7b0t219;7s15b0t220e-3856;97s3b1t210;3s13b0t221;2s16b-1t222e79;20s5b1t224e-55;285s2b0t225;5505s11b-1t226;145s14t227$e\4740\38827\13815\5 Agility\11174=1,11137=1@e\884\38825\13746+$k1 Armor\11137=3@e\963\38845\13937+$k1 Weapon Damage\11178=2,11176=2@e\908\38833\13858+$k1 Health\11137=6
$51;US;Thorium Brotherhood;Yorek;The Ironsong Tribe;13;2;61;5:247,1:277;1;.s1;16;2123000;;;;.q1;51962s9f80t213;1s8f71t214;13354s12t215;23039s10t216e4740;1209s6t217;32683s1b582t218;6s7b0t219;7s15b0t220;97s3b1t210;3s13b0t221;22s5b0t224e-3832;285s2b0t225;5505s11b-1t226;145s14t227$e\4740\38827\13815\5 Agility\11174=1,11137=1@e\908\38833\13858+$k1 Health\11137=6
$51;US;Thorium Brotherhood;Yorek;The Ironsong Tribe;13;2;61;5:247,1:277;2;.s2;17;0000000;;;;.q2;51962s9f80t213;1s8f71t214;13354s12t215;23039s10t216;1209s6t217;32683s1b582t218;6s7b0t219;7s15b0t220;97s3b1t210;3s14b0t221;22s5b0t224;285s2b0t225;5505s11b-1t226;145s13t227$

I initially tried it with just the windwalker export then I had it do BiB for Brewmaster and Windwalker additionally to see if it might self-fix whatever the formatting problem is. No dice

BiB runs ALL THREE at the same time, so no need to do each one separately; as long as your spec priority is how you want it you’ll get the right optimisation IF you use an off-spec.

Try fresh Armory update of the character concerned - Import data from game (make sure you open all your Artifacts), “Armory Update”, then re-import to BiB data box & run BiB.

Then try export back to game & see if there’s any difference…

EDIT ; AMR is intended for (at least) level 100 characters; based on your gear it isn’t obvious that you’re any higher than L60…

yep in my post I said this was for a level 61 alt (so no artifact)

Only point of me mentioning doing it 3 times is initially AMR did only know about 1 spec. Each time I set the spec on the web client it added a new set of info which I was hoping for debugging purposes would fix the glitch.

I did try reimporting fresh.

I do understand that the main intent is for high level characters but I don’t remember seeing anything official from AMR staff that it is supposed to glitch out with characters < 100.

@yellowfive,@Swol - can you point @Thermight to the relevant post that outlines sub-L100 limitations… I’ve seen it somewhere but can’t remember where. :frowning:

So far all I could find is a comment from them 5 days ago acknowledging someone elses’ <100 character BiB import/export working properly and that they’d look into it:

I think that the error is coming from some possibly armor enchants you have on your gear? The display name isn’t getting parsed correctly it seems, the extra dollar signs in it are messing with the parser. I’ll try to add something to handle that on the server side.

Give this another try, I think it should be fixed now. These can be a bit tough to debug because I can’t really load an import in-game for a different character than my own… but I think that I found the issue and fixed it.

1 Like

Thank you I will try again and report.

Yay it worked. Thanks. My levelling buddy is an Enchanter and I’m a jeweler