BIS, Gear Checker, and BIB not able to set Strategy

I keep getting the error The specified gearing strategy could not be found: b15647f0368d4abb832d8d4576f8f770__slim when i try to use any feature besides Gear Check.
I have deleted the Custom Gearing Strategy, reloaded character. I cant even change back to the default strategies. The drop box just says loading… any help would be appreciated.

What happens when you refresh the web page, go to the Best in Bags section, and press the Find Best in Bags button? Are you able to see the list of strategies in Step 1 and change it?

I can see the list but i am unable to select anything. Clicking the Set Strategy button does nothing.I can switch specs to Arms and select strategies there but when i hit find best in bag it gives the same error.

Do you see any javascript errors when you are doing this? Seems like something is preventing the page from functioning.

No I have not had any. I disabled by blockers and cleared Cache. I am running firefox 62.0.2. I was using the optimize yesterday just fine till I did a import to check gear. I also get the same thing in Chrome as well. I was able to switch to an alt and it worked fine. Its just my warrior having the issue

When you come the page fresh (reload it), go to Best in Bags, press Find Best in Bags to show the configuration step, and open the strategy list, and press Set Strategy and nothing happens – could you check your browser’s console for either javascript or network errors? In Firefox you can show it by going to main menu, web developer, web console.

I am having an issue similar to this one. I deleted some of my old strategies and now for the Pick a Gearing Strategy just sits at “loading…”. If I try and select any other strategy it does nothing and I can no longer run any BIS, Gear Checker, or BIB. Wasn’t sure if I should make a separate post for my issue as I am new to the forums and this issue is pretty close to mine.

I have tried refreshing, reopening the browser, logging out and back in. Nothing has worked so far and it is still currently stuck.

I’m also having issues with Set Strategy. It defaults to defensive and every time I set to “all offensive” it doesn’t take and sets to all defensive.

[Show/hide message details.] TypeError: a is null[Learn More] optcomponents.js:30:262

That is what the console is showing when the set strategy is clicked

Thanks for the error info – I think it’s something to do with deleted custom strategies that were still in use on a saved profile.

I posted an update that I think should at least let you pick a different strategy now. I’ll have to mess around with it some more to try and reproduce the steps that cause the error in the first place.

That indeed did work. Thank you