Buttons not working on website

I am trying to optimize my gear, clicking on “Do A Gear Check” and all the other buttons, nothing happens. I’ve tried clearing my cache as well as trying different browsers. Still not working

1 Like

can confirm. after importing gear from the addon, none of the website buttons work.

1 Like

Do you see any errors if you open the console in your browser?

Are you blocking any scripts on the site?

turned off uBlock and ScriptSafe Chrome extensions, however buttons still don’t work.

errors from Chrome console:

wowitemlist.js:1 Failed to load resource: the server responded with a status of 500 ()
gearexplorer.js:35 Uncaught ReferenceError: WowItemList is not defined
at new OptGearExplorer (gearexplorer.js:35)
at Object.init (gearexplorer.js:38)
at Object.initComponent (trcomponents.js:43)
at trcomponents.js:75
at NodeList.forEach ()
at trcomponents.js:75
at Array.forEach ()
at HTMLDocument. (trcomponents.js:75)
optimizer.js:43 Uncaught TypeError: Cannot read property ‘bind’ of null
at HTMLDocument. (optimizer.js:43)

also tested in Firefox. same errors in console.

Seems like an error downloading one of the javascript files… maybe an issue with our CDN for some people in certain regions. I’ll try to follow up with them – do you have anything that might block certain domains, e.g. Microsoft’s CDN?

If you try to browse to this file, do you get an error or see a bunch of text:





Server encountered an internal error. Please try again after some time. RequestId:24c27c0c-801e-0091-1427-1558dc000000 Time:2019-05-28T07:34:35.4377296Z



Strange… what happens if you clear your browser cache and try again? I’m looking into why you would get that error… it should be delivering that file to you via a CDN.

I did a website update that might get around this issue for the couple people experiencing it while I follow up with our CDN provider. Clear your browser cache, close and open a new browser window, and reload the website to see if you are able to use it now.


@scfone If you get a chance, could you try that link to that javascript file that gave you the error message and see if it works now? I followed up with support at our CDN and we think the issue has been resolved.

Yellowfive…I cleared my cache again…logged back in and I can now use all the functions without any errors…thank you very much for your help !!!