Certificate Expiry

A few minutes ago your SSL certificate expired:


Looks like you need to renew with GoDaddy or get a new cert from another provider and authenticate it.


Fix please! Not secure messages make me lose sleep at night!

1 Like

I cannot access Ask Mr. Robot. My browser Firefox blocked the access due some kind of site validation is expired. Fix that problem please.

Same issue… Chrome just blocked me from going to the site because of an expired SSL certificate.


This is quite embarrassing

Seems cert has been updated, but the site is still not functioning for me.

Wanted to follow up with the same report as above
Browser = Chrome

Same issue here. Earlier I was unable to get onto the site due to security. Now its showing up as text only as per the above post. Chrome Firefox IE and Edge browsers all the same

Working on it… the certificate is taking a while to update on our CDN.

1 Like

I have updated the site – most things are working, still fixing up an issue with the simulator client (it isn’t auto-updating correctly). Everything else should be working again – you will need to log in to the site again though.

Sorry for the inconvenience, let me know if any issues persist.

I couldn’t get the old CDN to update fast enough… so I made a new one! The site might be a tad slower until everything gets cached.

1 Like

Thank you for your replay and the fix: “Ask Mr. Robot” is available again. Many thanks.

Hi there,

I’m still having issues with having the website correctly load after the certificate issues.
All I’m getting the text only version as mentioned by Normfett.

I’ve cleared all caches, changed DNS, flushed DNS, tried to access the site using brand new user profiles on Chrome and Firefox.

I really hope someone can help me out as I’d like to continue to use your services.

Sounds like maybe something is cached… there is one other user having a similar problem with the simulator client, he is just unable to get anything from static.askmrrobot.com to load…

If you browse to this url, do you see an image in your browser?


No, I’m getting an unable to connect page (firefox)
Also tried with new/clean profile in Firefox and flushed dns cache.

Chromium browser also produces an error


Also tested on my laptop with same results.
Also tested with VPN using VPN DNS (connected to usa), same result.

That is strange… it’s like your system just can’t resolve static.askmrrobot.com or is explicitly blocking it.

Do you have anything in your network that blocks certain domains? That is a custom domain that points to our new CDN, maybe you are blocking the CDN that we use?

I figured it out :slight_smile:

I did a tracert to askmrrobot and saw microsoft addresses being traced.
Then it hit me, I’m using the Simplewall firewall application on my windows 10 pc’s and have the extra (ip) blocklists enabled. Through the Simplewall log I was able to figure out which specific rule(s) I had to disable to make askmrrobot load again. In my case it was rule “update_13.107.246.10”. (but I already had a few other rules disabled as well).

Hope this might help others in the future and now if you’ll excuse me, I have some simming catching up to do :+1:

Glad you figured it out!

Yes, we moved our CDN from Amazon to Microsoft, so it should have occurred to me that some people might be blocking certain domains.