Custom gearing simulation keeps erroring out

I keep getting errors when I try to run a machine learning gearing strategy for Zulazeel.

It says “Object reference not set to an instance of an object” most times. Sometimes its a divide by zero or out of range error. Its been going on for months now. If I try to run the vers 2 I get an access error that crashes it and the game too.

Please help.

I have asked about this several times both in these forums and by other methods and have not received any reply at all. A response would be appreciated.

I’m no expert, but I think that’s a .net error. My guess would be that your version of the .net framework may be in need of an update. Windows update should automatically tell you if an update is available (or you can force it to check manually if you’ve turned it off). If that’s not the issue, then someone closer to the technology would have to help you.

If you give us a link to the report that shows this error, and also let me know the date that you received the error, we can try to look up more details.

I reinstalled the client and ran a simulation on Zulazeel-Scarletcrusade and got the following error message.

“last completed run:
status: Error

I got a different error than usual on the website at the same time:

“Index was outside the bounds of the array.”

I would appreciate any insight as to what is wrong

Is this enough information or do you need something else?

Should be enough, i can try to look up more details – it can sometimes take a bit to track down bugs in the gearing strategy runs, because it’s probably specific to a particular setup, so we have to tie up a dev machine to crank out the strategy with the debugger attached, etc. etc. Hopefully I can pin it down though, have a bunch of other tests running as well.

I just tried again and almost immediately got an error:
“Object reference not set to an instance of an object.”

Client provided this link:

I tried this one from data with my bank closed because I thought maybe I had some strange item in my bank that was crashing it, but if it has anything to do with a particular item I’m either wearing it or have it in my bags.

We’re working on a big update for tomorrow or Friday. I’ll try it again after that update to see if it fixes it, and if not, try to get to the root of it.

Just tried again with current gear for the version 2 gearing strategy and got:

Object reference not set to an instance of an object.

I’ll try running it overnight on my dev machine, see if I can catch the specific error.

I just ran this with no error on my dev server… gonna try seeing if the error logs shed some more light on it…

Thank you.

I do have what Microsolft update says is the current dotnet

It worked with the newest update, but I had to slow it down. I don’t understand why I’d need to do that, but when I ran at ‘normal’ speed it got an error trying to access protected memory and the error said I might have corrupted memory.

I ran a memory diagnostic that turned up no problems, but I tried a slower speed run after that and that one and it a second run both worked. Maybe it got too hot before, but I don’t see why it would since the computer runs much harder than that when I run several games at once.

In any case, it’s working now.

Cool – yeah I’ve seen one or two other people get an error like that… couldn’t find much information on it. Could be an obscure bug somewhere in the .net core code (which I can’t change unfortunately… we write our stuff on top of that framework). Or, it could just be super sensitive to memory errors, and the type of work it is doing happens to stress memory in a particular way. Hard to say…

For whatever its worth, I’m running a 6700K at 4.3Ghz and 64GB memory overclocked to 3000 and 2 980Ti video cards in SLI and Gsync. The video shouldn’t matter I’d think, but even on “slow” it finished in an hour what the Sim estimated would take 3 hours before it started.

I don’t know if any of that helps