Customs setups disappeared for a single character

Snapshot ID: befa1b0d20d047d4b92d96614823dce1

My custom BiB setups have disappeared from the website, for my druid only (other recently viewed toons are fine). Some setups are possibly still there, but not visible, as when I tried to recreate them I can only get to 4 setups before it gives the “too many setups” error (should be 7 possible for a druid?).
In game addon, and blizz equipment manager still have my 5 old setups (I have disabled “creating equipment manager sets”). I have tried deleting as many setups as possible from the website and importing from addon, but nothing much seems to happen (gear is imported from bags, but not the setups).
Its possible I hadnt actually imported and optimised the druid in a long time, until just the other day when I first noticed the problem.
Any ideas for things I should try?

You can create one setup per spec, and then 3 additional for any spec, for a total of 7, but only 4 for any one spec. So if you are on resto spec and have 4 resto setups, you can’t add another. You can switch to a different spec and make one for balance, feral, or guardian.

If you haven’t done anything with this character in a long time (since before blizzard changed the policy around character data), it’s possible your info had to be removed :frowning: You should be able to start fresh and as long as you load the character once a month (or never load from the armory) it will always stay there on the site.

We put up a notice when we made the change letting people know that if you had an old character laying around you needed to update it once from the addon to ensure data wouldn’t get removed. We knew not everyone would see the message but we had no choice in this matter :frowning:

Cheers for the reply Swol, I do have a vague memory of the data retention issue message, which I why I mentioned the age of the profile. I think I was busy irl and obviously never updated properly at the time.
My problem with the cap on number of setups resulted from spam-clicking the “Add a new setup” button, renaming each without actually assigning the different specs in between. As you suggested, clicking the spec buttons up top adds a new setup for each, up to 7.
Thanks for the help!