Data String not in correct format

This is the message I continue to get when trying to import from the addon. Ive uninstalled and reinstalled disabled all other addons but continue to get the same message

Have you inadvertently added something to the import string? Occasionally I get a stray ~ in there because it’s my push-to-talk key and it’s so automatic that I forget when I’ve pushed it.

Someone mentioned that using some linux thing was sometimes appending a character to it… just hitting backspace one to trim it off made it import after the error message. Not sure if that is relevant.

Cant really say
I’m Cntrl+C / Cntrl+V straight from export into best in bags in AMR. The another Cntrl+C / Cntrl+V back into import box. Whats strange is that it copies and paste the first time going into AMR but coming back out into the addon its like something gets added. Below is what I’m pasting into AMR. Ive attempted to look at it line by line but makes my head hurt

$51;US;Skywall;Decrepit;Global Addiction;10;2;39;13:4,12:35,10:258,14:1,4:240;3;.s1;31;0000000;;;;.s2;32;;;;;.s3;33;1200000;;;;.q1;59s8;1337s7;51995s6;68962s16;7s3;1s14;1s13;22s5;280s2;.q3;17748s8;7s6;34237s11f86;0s12f86;13926s9e4720;1s10;56331s1;6s7;6s15;91s16;7s3;1s13;0s14;23s5;280s2;.r;_;.inv;765;9;11;144;277;4;498;2;610;129;1;3;136;3;404;1;821;2;1;6;479;32;0;0;0;0;270;17;1351;173;69;443;0;228;59;964;238;193;484;4;477;746;0;884;2;38;105;1;50;3;1;1;35;1;1;1;1;47;12022;15435;30527;9134;33213$

And this is what I get in return to copy and paste back into the import box

$51;US;Skywall;Decrepit;Global Addiction;10;2;39;10:258,4:240;3;.s3;33;1200000;;;;.q3;17748s8t62;7s6t63c1;34237s11f86t64;0s12f86t65;13926s9t66e4720;1s10t67;56331s1t68;6s7t69;6s15t70;91s16t71;7s3t72;1s13t73;0s14t74;23s5t75;280s2t76$e\4720\38679\7418+$k1 Health\10940=1
$51;US;Skywall;Decrepit;Global Addiction;10;2;39;10:258,4:240;1;.s1;31;0000000;;;;.q1;17748s8t62;7s6t63;34237s11f86t64;0s12f86t64;13926s9t66;1s10t67;56331s1t68;6s7t69;6s15t70;91s16t71;7s3t72;1s13t73;0s14t74;23s5t75;280s2t76$
$51;US;Skywall;Decrepit;Global Addiction;10;2;39;10:258,4:240;2;.s2;32;0000000;;;;.q2;17748s8t62;7s6t63;34237s11f86t64;0s12f86t64;13926s9t66;1s10t67;56331s1t68;6s7t69;6s15t70;98s3t72;1s13t73;0s14t73;23s5t75;280s2t76$

Yeah - there is a different format for going from the game to the website, and going from the website to the game.

I tried your data that goes from the game to the website and it worked…

Very strange still getting the error. deleted the wtf folder and did all I can think of its not a deal breaker by any means ill just manually equip my gear. just kinda caught me off guard is all

If you copy it from your post on this page rather than straight from the game, does it work?

no it doesn’t I tried that as well

it very strange up until a few days ago it was working as intended, I added no other addons or changed any key bindings

the only thing that appears different is that when I paste back into the addon its all one continuous line of text NOT like you see above not sure if that matters. Ive even attempted to right click cut and paste but that option doesn’t seem to be available when pasting back into AMR

going to the website from the game isn’t the issue, that seems to copy and paste just fine. Its going from the website to the game is the problem using the same copy and paste method

I’m sorry if this is considered a necro since the post has not been updated in 2 weeks, but I was having a similar problem to the one OP was having. I think I found a solution to the problem I was having.

I had heirloom pieces which had enchants that were not usable at the current ilvl (+3 stats on the chest, +7 armor on the cloak, and a Pandaria level inscription enchant on the shoulders). Once I destroyed the pieces and created new versions of those heirlooms I was able to export the data (this had always worked fine) to the website again and successfully import from the website to the addon.

Not sure if this will fix OP’s problem, but if anyone else stumbles across this, maybe it’ll help.