Desktop app closing on its own

I usually set my sims to run on both my desktop and laptop when I go to bed at night but recently, when I wake the client has shut itself down on both computers and only one-ish sim has run. Is this a change on your end?
OS: up to date windows 64bit on both machines

We haven’t updated the client recently, but we will be putting out a significant update soon.

Are there any errors when it shuts down? If you open a command prompt and run amr.exe from the command prompt rather than double-clicking the file from file explorer, the command prompt window will stay open after an error occurs and sometimes have more information about the error.

It just happened while I had it running in the background… I don’t know DOS, when I use the run cmd I’m getting an error that ‘run’ is not recognized as an internal or external command

I see the server update and v.420 are deploying now so I’ll try back a bit later

In File Explorer, go to the folder with amr.exe in it. Press SHIFT+right-click somewhere in the blank space in the File Explorer window to get a context menu, it will have an option to “open a command prompt here” (or maybe open PowerShell window here – either will work), choose that.

Now you have a command prompt window opened and the directory is set to the right place.

At the prompt, just type:


And that’s it! It will run as usual, and if an error happens, the window will stay open and probably show a message with more information.

The same happened to me now, two times today during the same simulation, after updating to version 421 this morning.

I’ve seen this behavior a few times in the past, but I blamed it on me being absent-minded and closing it myself for whatever reason.

I’ll try running it from the command prompt as well and seeing if anything shows up.

I just had it happen again with the power shell open, and there’s no error message.

Only that remained visible, and it returned to the prompt. No error message/last completed run message remained visible.

Strange… not sure what would cause it to exit with no error…

Does it quit only when running a simulation? Can you get a specific simulation to cause it to close?

So far it has only been during a simulation. I ran a 5-6 hour long blood DK gearing strategy earlier, and it happened 3 times total during that one. I could always resume it by restarting the client.

Now in the evening, I ran 10-15 quick single runs, all less than 60 secs each. Blood DK again. It happened during one of them, the others finished without any problem.

Like I mentioned in an earlier post, I’ve seen this before, but very rarely. Today it happened a lot, and the only difference I can think of is downloading version 421. Didn’t make any changes to my computer, other than some Windows updates a couple of days ago.

I’ve been looking into a server issue that is slowing down our web servers today… it’s possible that there is something timing out when that happens, hard to say if fixing that up will resolve this issue or not.

I was just testing a bit… and it does seem that if it is having trouble connecting to our server, it can sometimes just close without a message… I’ll look into improving that message.

The behavior Dlo posted is exactly what I’m running into, even in Powershell. Finally got through a resto druid sim today after the client shut itself down 4 or 5 times. When it finished I got this error message:

Ask Mr. Robot client version 421 loaded.
User tharadoon connected.
Running in Max performance mode.
Global Network is disabled.

Press any key to open the main menu at any time.

Ready to simulate, go to to submit a simulation…

last completed run:
status: Error
run time: 4.488 sec

I was running this from the reg client not powershell

It’s possible that some data points are missing… that’s what usually causes that error.

I can try running your simulation on one of our test servers… see if something is causing the simulator to crash with your particular setup.

If you run the program from a command window, even if it crashes, it can’t cause the command window to close… it will always stay open afterwards. What happens? Does it just exit with no message at all and go back to the command prompt?

It looks just like what dlo posted above. No error message, it just stops running the sim. Same behavior when I try to sim dps specs/classes. Tried all 3 specs on the DK, client and powershell were consistent in their behavior across any class/spec I tried.

Just an update, the same thing happened to me again today with version 423. Same thing as the picture I posted earlier in the thread.

I have the same problem. Yesterday i startet 2 Simulations and both are crashed with no error.

Is there an update on this? I keep the client on for GloNet and I’ve noticed it closed sometimes when I left it open, and no indication the computer restarted. I did once get an error message when I started it, but closed and restarted and it ran fine.

I did update Windows recently.

Also, I’ve opened a Powershell, and it insists “amr.exe” is not a valid command to use.

`PS C:\Program Files (x86)\World of Warcraft\AskMrRobotClient> amr.exe
amr.exe : The term ‘amr.exe’ is not recognized as the name of a cmdlet, function, script file, or operable program.
Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1

  • amr.exe
  •   + CategoryInfo          : ObjectNotFound: (amr.exe:String) [], CommandNotFoundException
      + FullyQualifiedErrorId : CommandNotFoundException

Suggestion [3,General]: The command amr.exe was not found, but does exist in the current location. Windows PowerShell does not load commands from the current location by default. If you trust this command, instead type: “.\amr.exe”. See “get-help about_Command_Precedence” for more details.`

power shell is a little different than a normal command prompt, you need to type:


Similar concept to how linux shells work.

If you have the latest version of the client, I did fix an issue in the last update that would sometimes cause it to exit without an error message. It might catch your case now.

1 Like

What’s the last update? 429 is still doing it.

And caught this in Power Shell:

There was an error connecting to the server, or you may need to log out and back in.

Please go to the Contact page at and submit a technical support request if this error persists.

Is that server thing still ongoing? Is this just related?

It is probably related – if the server hangs for a bit, could cause your client to disconnect. The next update should fix one more case where the client might exit instead of try to reconnect, that might take care of this once and for all.