Equipment Manager sets in WOTLK broken

Support code cc9d8a3fb7614216820a785e14ab2889

Something seems to have messed up the built-in gear manager sets, and Blizzard’s own code is throwing LUA errors when I click the button even with zero addons loaded. How can I clean this up?

Update: The issue seems to have been created when I renamed the profile on the AMR website and tried to delete the obsolete profile – I get prompted to delete but it clearly doesn’t clean up properly internally. So this may or may not be an AMR issue…

Interesting – yeah I would report the issue to Blizzard if the error is originating inside their code with no addons loaded. In theory a 3rd party addon should never be able to do something with the API that causes Blizzard’s code to fail when no addons are loaded.

Update 2: Is it perhaps due to the AMR profile name being longer than allowed by the WoW Equipment Manager UI? “Blood Tank Cheap Gems”

I actually haven’t tried that case… so I’m not sure what would happen! I can put it on my list of things to try out when I get the time.