Error message (Error Sequence contains no elements) when using BiB on Classic

Snapshot ID: 40d89cb0147544ea866f386b208ee595

All my characters are on Windseeker, a Classic server. I am using the Classic version of AMR from Twitch, updated to the current version. I only have Classic on my computer, I did not download WoW BFA. I am using the Classic version of AMR on the AMR website. When I import my 60 rogue, (and many times before she was 60) and asked for BiB, everything worked perfectly.

All the other characters I’ve tried (22 Mage, 39 mage, and a 42 hunter) generate the error message Sequence contains no elementsmessage.
This is what I’ve done so far to debug (several times):

  • Logged out of all characters
  • Rebooted computer
  • Uninstalled AMR using Twitch.
  • Deleted all instances (that I could find) of crumbs of AMR in my computer files.
  • Deleted all characters on AMR website except the current (failing character).
  • Reinstalled AMR
  • Copied the AMR ingame string
  • Pasted to Classic AMR webpage
  • BiB > Fails with error message

We will take a look. The update we did yesterday must have a bug in it - we’ll fix that up ASAP. Our main dev is on west coast time so he isn’t awake yet.

Give it another try – I just updated the website with a fix. Sorry about that… we added in a lot of extra logic to improve handling of set bonuses, and a few cases caused issues for characters without any set items!

I haven’t tested it on every character but that seems to have fixed it

I still have it on my feral druid. f08ed6bb06b74be1a2fbb2ef8bf780a5

I can’t seem to load that snapshot ID. Could you press the “help” link next to the big Best in Bags header, then click Create Support Post, and paste the generated snapshot ID here? With that I can try your case.

2f7304f82fc34270882c321e07a38df4 . I filled the contact form (my classic server wasnt on there though :slight_smile: transendence)

That is the error ID, what I’m looking for is a different help code that we use for technical support:

First click the Help link:

Then click this button on the popup:

It will generate a 32-digit code. Paste that here and we can try your case.

Also, the region/realm/name pickers on the support page are only for Battle for Azeroth right now. Usually if you provide a snapshot ID by following the steps above, or provide the error ID as you did, we can figure out which character it was for.

Using snapshot ID generated via the Help link next to each feature and posting it on the forum here is by far the fastest way to get help with any issue. (We should probably update the support page to tell people that, it’s a relatively new feature.)

Ah got it :slight_smile:


OK reload the web page and give it another go – should be fixed for all cases now.

Yep, it’s fixed now! Tyvm :slight_smile: