Force Tierset does nothing

Just tried the force setbonus for guardian druid as the optimizer is not using it. Problem is that forcing it still does not make it equip the 4set or even 2 set. Anything wrong with the force or am i doing something wrong?

We just added that in yesterday, so there might be some kinks to work out. We’ll take a look at this and see why it is not working.

Figured it might be something like that. Its the only one ive noticed on, i’ll add more if i see.

I’ll take a look – we use a different method for ranking those particular set bonuses and it looks like the new setting is getting bypassed. I’ll try out a different implementation and do an update today for people to try out.

I’ll add my protection paladin as it seems to have same issue, if that helps you. 77a9a4e408b64600983622f379674e44

I’ll adjust it for protection paladins a bit, that ran into another interesting case that needs some special code.

To add some anecdotal info to this if it helps at all. With this option turned off AMR undervalues the prot paladin tier sets, if not devalues them slightly for some reason. When I turn the force tier set option on nothing happens but AMR suggests that manually equipping set bonuses are an 8-10% downgrade, even when the alternative gear is almost identical in stats/ilvl.

If you look at manually equipping/locking in tier hands to complete 4 set AMR suggest this is a -9.14% downgrade even though the two items are almost identical (except one is tier).

I’ll take a look, there’s something about that 4pc bonus that it’s having trouble with, not sure why.

I just posted an update that I believe should resolve the issue with the protection paladin set bonuses. The issue seemed to only happen when using the High Haste build, or sometimes with a custom secondary stat target.

its still not working for me - it only gives me 2 piece bonus even though i have gear for 4 piece bonus

I would need a snapshot to look at your case in more detail.

a snapshot - is that the amr export string?

EDIT nvm found out how to make a snapshot (i think)

Thanks, I’ll take a look. Not sure why the option isn’t working in that case… this particular set bonus is really finicky with the way that we implemented the force set bonus feature. I’ll mess around with it a bit.

I adjusted it a little in an update just now – it should more consistently choose the 4pc with the “force” option selected. I need to work on a different implementation to guarantee that it will pick it, but that will take more time.

that seemed to do the trick for now - thank you :slight_smile: