Gear imported from addon doesn't match game

Hi, I’m having a similar problem that started yesterday on 18Jul2017. All of a sudden, I check best in bags after a raid to check if new gear is better (according to AMR) and the iLvl of my gear doesn’t match what’s in the armory. Game says 911 and AMR says 886 and the app is obviously making the wrong choices and is therefore ineffective. It appears to me that the AMR app needs an update after a patch from Blizz.

I moved this to a new topic because it is unrelated to the other post.

It sounds like perhaps your relics didn’t import maybe? That happens sometimes to people, something I’m looking into. It can almost always be resolved by simply opening up your artifact UI again (shift-right click on your artifact), then export again.

I’ve not complained because I thought it something with a patch, but this has been going on for quite some time. I’ve tried everything I can think. Let’s take my monk, primary is windwalker, offspecs brew and mistweaver. I get new gear, I go to Mr Robot, logon, go to bank export my stuff to mrrobot, go to best in bags, ooo different gear, copy my config and go to export to addon, ctrl c, ctrl v, seems to take, but I have no updates .I’ve tried deleting the amr spec and still I don’t see a new gear spec for windwalker. It’s not just my monk, I’ve tried this on my priest as well. I don’t know what is going on with the gear manager, but it’s not taking your string you provide for import the mrrobot addon. It has become an issue as you gave us this cool ability and now it’s broke…it has been broke for me for quite a while at least 2 patches…I don’t like to whine, but I’m whining as a paying customer now because I’m working on my offspecs and alts.

Can you post the addon export string that you copy from the game to our website here? I can then use that to reproduce what you are seeing.

Also, can you tell me specifically what you are seeing on the website that does not match what you are seeing in game? e.g. is a particular item missing, or have the wrong item level?

I am having a similar issue with exported information from Ask Mr. Robot. The BiB information is completely different and gives incorrect item level and gearing options. Here is example of an export that it happens to.

$54;US;Proudmoore;Sashay;Safety Scissors;5;1;110;10:778,15:80,12:800,13:33,14:666,4:798;2;.s1;22;;;;;;.s2;23;3131312;;;;;.s3;24;;;;;;.q2;128825s16b739x147097y3915z-7;3627s12b1072b1759x578e5428;1315s2b-3529b1521b1966b45e9;669s9b-3532b1521b1966b45;2338s8b-2011b246b1720b45x0;2311s6b-2001b236b1720b45x0;5395s14b-2011b1775b74;2539s13b-1904b301b1720b34x0;144s15b-3522b1452b2036b45e-1;2s1b-2101b1864b228;2s5b-2082b2046b33;1s3b-2094b341b1720b36x0e493;4478s11b-105b111x0e-501;704s10b-2093b1859b278;2s7b-2142b2056b86;.r;_;.inv;2996;1;1308;2528;115;3337;3762;1;7792;0;0;37;0;0;11593;584;0;0;0;0;0;31;4341;256;1291;222;1316;82;1;1;2455;988;7685;287;633;17440;534;0;0;1371;6116;163;1246;1928;6;4952;8050;3170;9820;679;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;1;0;0;0;0;0;0;0;0;0;0;0;7;0;0;29;63;0;367;108;0;0;867;996;0;0;0;0;0;0;0;0;1;0;0;0;0;0;0;1705;0;1;0;0;0;0;0;0;1;0;324;1916;0;549;213;5;1828;798;2048;3179;313;0;0;0;0;3;1;1;0;0;227;2368;331;313;153;0;0;13;980b740x141518y5564z29;41b-2x-5835;1351;684;1541b1073b1759;11b-111b70b41;1115;0;0;0;1;0;5;395b-111b111;2b-111b111x10307e5428;214b-1998b1956b45;2190;1154b-2031b185b1609;111;39;1695;816;395;0;144;12;1;1;860;47;266;199;1362;780b123b70b41;179b-1759b1759e5;2546b-2088b326b1720b33x-21363e0;4b-2064b1839b225;6b-2064b2031b34;19b-3520b1460b1834b237;151b-2106b2061b36;2b-2097b2061b36;0b-2097b2061b36;1b-2097b2061b36;27b-2067b311b1720b34x0e-5;1b-2075b1849b228e0;54b-1865b1465b172b237;100;382b-2071b1835b235;146;174b-2050b154b1852b51;2b-2057b172b1834b51;1466b-2007b147b1809b45;1468b-2016b1840b131;1b-1956b1956b45;17b-399b223b131;8b-339b148b60;121;289;144;0;0;1;274;507b-1925b2056b86;2b-2142b2056b86;424b-2112b209b1817b45;2b-2061b187b1637b237;9;212;0;0;1;15;176$

One thing I notice right away – all of your relics are empty. You probably need to go in-game and open up the artifact UI for your weapon (where you spend artifact power). Then also go to the crucible and open that up, and optionally preview any relics you have in your bag.

This is the only way our (or any) addon can get your relic and crucible information unfortunately – you have to actually open the UI in-game.

Then export again, should be all fixed up then.

Followed your instructions and it seemed to fix it for most of my characters. This one that started this whole mess is still giving incorrect item level.

$54;US;Proudmoore;Mylee;Safety Scissors;6;1;110;13:81,15:1,12:602,1:769,14:710,3:734;1;.s1;6;3123213;;;;1,1739,39,5,-743,-4,5,1,1,0,0,0,0/2,698,39,-3,-737,4,-2,1,1,0,0,0,0/3,699,40,-2,-738,-1,-2,1,1,0,0,0,0;.s2;7;;;;;;.s3;8;;;;;;.s4;9;;;;;;.q1;128858s16b722x141515y-4134z14963;5478s13b-115b965b1956b45;2756s9b-1762b1759;305s8b-2008b1966b45;1672s10b-2001b1956b45;7915s15b-2086b1849b225e5436;32s14b-2079b2046b33;117s5b-2089b1864b228;3s1b-2087b1859b228;59s11b-2087b2051b36e-8;546s7b-2072b1844b236;1s3b-2090b326b1720b44x-22124e12;1888s2b-1995b1759b237e457;2006s12b-1762b1759x28e-468;728s6b-3529b1436b1859b278;.r;_;.inv;6948;33824;11413;140;4;654;55;2472f127;240f36;4735;0;0;1;1611;4;8982;8021;1409;6703;563;7666;4;13706;0;63;0;1342;5493;213;2631;6;2042;0;2973;1;185;1;12;2;5;0;313;1;2732v110b3623;284v0b0b1;380;13;457;2b-2899x141275y5820z3917;252;561;39;1010;50;2;0;2;3345;3;2;0;2;2;40b812b189b1611;21b-1795b185b1609;2740;0;1947b-1879b351b1712b8x-20794;1539;329;395;310b-2051b1860b184e5429;708;47;465;289;922;574v0b107;2v0b0;65v0b-5b1;83v0b3e468;190b-1816b1759e-453;243b-2003b1769b237;2518b-2101b1864b228;2b-2092b1864b228;5b-2097b2061b36;9b-2087b2051b36;8b-2097b2061b36;1b-2097b2061b36;60b-2062b1834b226;106b-2095b341b1720b36x4e-15;307;376;3687;0;1;3;0;15;259;253;661b-2092b217b1839b101;0b-2157b212b1844b101;1b-2147b203b1651b293;0b-2157b224b1832b101;1b-2142b203b1647b292;1b-2147b222b1632b293;1b-2152b216b1643b293;0b-2147b217b1637b293;238;137;55$

That character has no relics… if you open the artifact UI in-game it should fill them in.

I have also experienced this problem from time to time.

Today I was deeply annoyed by it when I used AMR on a new computer. I found the only cure was to open my bank and void storage, then go to the Vindicaar and open up the netherlight crucible in every spec.

The first time you use the addon on a character, you need to initialize it. This involved opening your bank and void storage once, activating each spec and opening your artifact UI once, and opening up the netherlight crucible once for each spec. If you have relics in your bags, you also need to preview each relic once.

After that, the addon will automatically keep things in sync (because the only way to change any of those things is to open them up in game).

The reason you have to do this is a limitation of Blizzard’s in-game addon API… for whatever reason, they only let you get at this information when the associated user interfaces are visible on your screen. Not how I would have designed it… but it is what it is.

I have the same Issue. When I try to Import from the wow armory It Imports wrong Ilvl and gear too.

The armory unfortunately does not have netherlight crucible information – you need to import from our addon to accurately load your character, or manually choose your crucible powers after loading from the armory.