Gear Strategy Sim Issues

With the recent changes to the Gear Strategy Sims, they take a lot longer to run. This seems to be causing other issues and never actually finishing sims in some cases.

Yesterday I tried to run a gear strategy for my resto druid. I started AMR on both an i7 6700 & i7 4790, both set to Max, it ran on both for 4+ hours, then I added 2 sessions from a ryzen 1700 each set to 8 cores for another hour… It never finished because there was an update to the simulator and the report said to try again.

I started it again last night on the ryzen, I knew the PC would go to sleep before it finished but figured I would finish it in the morning… Nope, there was an update, had to start over again.

Just started it again, on the 2 intel machines. After an hour or so they got up to chunk 50 something, but the page just said processing, so I clicked the refresh link on the page to try and see where it was. It said 5 / 1575 and the machines reset to chunks 10 & 11.

I know siming a healer will take awhile, but the constant resets are what is really annoying me. Since we no longer have any control over the error target of the gear strategy I can’t tweak it to run faster. Also because it takes so long, updates and other issues seems to be causing it to reset multiple times before finishing.

It is getting extremely frustrating to just try and run a single gear sim. Is there any way to fix it or any advice beyond running it on 3 reasonably fast machines and just hoping it finishes before the next update?

And it just started over again … Back to Chunks 6 & 7, went from 500ish / 1575 to “In Progress…”

I have not had major issues completing resto druid gearing strategies, and i don’t have a nearly the processing power you are throwing at it. One thing to know is that the website progress reporting is based on your clients reporting back in after finishing chunks, so it will take a few minutes for the website progress to report if you’ve reloaded the page. This is most likely what is happening when it says “In progress…” or “5/1575”. I have lost a couple sims to simulator updates, and those have been coming fairly often with the new patch out, so you might have just gotten unlucky with your timing there.

For reference, mine take about 6-7 hours mostly plugging away on a i5-4670 with some help from my laptop, which has some mobile i5-XXXXU, i’m not even sure what model. You’re probably putting out at least twice the cycles I am, so I’m surprised it would take that long. What boss script and rotation are you using for the strategy?

I’m using the default Raid Healing Krosus rotation, and a modified version of the same boss script.

I changed raid size / comp to match my guild, modified the AI healer values to match our logs, and am running with an extended time since I’m not actually trying to sim Krosus.

I ran a few single runs after making the changes to make sure the boss script still worked. But I couldn’t find a way to see what the AI characters were doing to validate any of the changes.

I know the extended time is a big reason for it taking so long, and I’m not so much worried about that as I am about it resetting.

I ran a couple a few days ago with a less modified boss script (only extended time & fewer raiders) and they finished fine. So I’m not sure if it’s the timing on the updates, an issue with my changes, a bug or just bad luck.

As I was typing this it reset again, the page is stuck at 722 fights this time, but the PC’s are back to chunk 5 & 18 after being up to 70 last I checked.

If I just need to throw more power at it I can, but since it seems to be 500-700 fights in I’m not sure what the issue is. I didn’t really pay attention to it yesterday to see if it was resetting since I just expected it to finish eventually.

Another thing that may be happening is that the chunks aren’t necessarily run in order. I’ve noticed that, especially when you have multiple clients going, that sometimes you’ll see it running an early chunk even though you are far into the strategy. I’m not sure if this is by design in how the site serves up sims to the clients, or if there is something else going on. I do know that if a chunk “fails” (say, if the client running it crashes), then the server will send it out again later to give it another try, so that could be contributing. If you want I can take a look at the scripts you’re using and see if I run into issues as well.

I think you may be right about it repeating chunks, I haven’t closed AMR on either machine, and I am now on my 4th trip through… While I was away it also jumped up to 1000ish fights complete so it seems to be chugging along even though the site doesn’t always report it or switches to “In Progress…”

It would be nice if there was a little more background info on how it works, or a logging options so I could see if what it was doing a little better. I see that there is a logs folder, but it’s empty

Having it fail to run multiple times and then watching the chunk numbers repeat multiple times with the site switching to “In Progress…” is disheartening.

If you refresh the web page, it can take up to 5 minutes for the total progress to update. Might try to make that more responsive in the future.

And yes, it is highly likely that the chunks will run out of order. It’s also unlikely that it is repeating chunks… what happens is that no chunk will run for more than 5 minutes before your client stops, then re-queues the remaining work if it didn’t finish the chunk. Then another client (or the same client) will pick it up and finish it. We do this to prevent any of your clients from becoming unresponsive for too long, and also if you have a really slow client, it won’t hold onto a chunk for a really long time.

If you have a case that is running unusually slow, you could give us a link to the report, and we could try running it on a debug server and see if there is something going on with simulating a particular combo of items, etc.

In theory… with our last update, if you have a long simulation running on an old version of the client, it should be able to complete if you keep at least one client running on the old version.

The site was sitting at 1063/1575 for at least 20 minutes before updating to 1087 then about 5 minutes later to 1104 before sitting again for over 40 minutes before updating to 1109.

Thanks for the info on how it works. I’ve been keeping a closer eye on it this past hour and it has definitely repeated chunks, it’s good to know how that works & why they are being picked back up.

Both my machines seem to be picking up a new chunk every 2:45-3:00, I timed 4 chunks on each machine and they all fell in that range, the 4790 with nothing else running on it seems to swap chunks more often.

I am closing in on 7 hours running on the 6700 & 4790 both hovering around 90% cpu usage. As I said before, I’m not so worried about the time, I can throw more machines at it. I’ve just never needed to before, and it seemed to be resetting and failing to finish, which made the idea of adding machines pointless since it seemed to restart every hour or two.

To see what the ally healers do, set the output to log when you run a single sim. All the actions are in the log section.

The default script purposefully inflates the AI heals to account for all the “passive” healing real healers so above these few heals in the script. Also, make sure to set the healer base item level in the script to the values you changed it to.

After 12 or 13 hours it got to 99% (1565/1575), but nothing was running on any of the machines. Restarted AMR on one of them, it wouldn’t load anything. Let it sit overnight, nothing … So another unsuccessful run.

Going to try running it on a Ryzen 1700, i7 6700, 2x i7 4790, and an i5 2500k at the same time … Hopefully that’ll be enough.

So it did the exact same thing, got to 1565/1575 and sat for over an hour, none of the machines are running any chunks but it isn’t finishing.

On the bright side it took less than 8 hours, on the down side I can’t run my gear sim… It especially sucks since SimC doesn’t support healers, leaving me with no way to actually test or get custom gearing info.


I decided to try running a sim w/ the default scripts and settings. It flashed an error message, something about server connection, but was too fast to read. Then it went to this…

I went to another machine, pulled up the sim report and it went to the same loading type screen…

So, any suggestions?

So I looked through the logs folder on a few of my machines and found a bunch of errors on one of them.

Could not broadcast status ‘status_13_5’ for report 12e157014663468a9bc2f611276d0f35. http status code: ServiceUnavailable

I’m assuming these errors have to do with why I wasn’t able to finish the last couple of sims. Anything I can check or do to fix this issue on my end?

When did you see those errors? We did have a problem with one of our servers for a few hours today, but it is fixed now.

I know you were having your problem before that, though.

I’d suggest that you post the Rotation and Boss Script you are using along with the settings used so we can help you test why it might be giving you issues. Even if the errors you ran into yesterday are due to the general server outage, I have not had any issues with resto sims (other than them taking a long time as expected) so we are doing something different.

The log errors start on 6/26 around 5:45pm EST and I have one every minute or so up until 6:31pm. Then again from 7:02pm - 9:32pm every with entries every 3-5 minutes it looks like.

All of them have the same basic error. Just different status / summary numbers, and across 2 different reports.

It seems like it was definitely something with the Boss Script. I started over today, making incremental changes and running gear sims after each set of changes. I was able to get all the changes in, though I changed the way I went about a couple of things in the script.

Here is a link to the last Sim I ran that never finished - LINK -… I think I know one of the reasons why, but not knowing how the sim works or how to change stuff it was kind of a learning experience, and it’s probably horribly wrong… but it was my first time messing with a boss script.

What did you change?

I had added in the passive healing of an ability as 0 cooldown and 999 duration. Switched it to 30/30 instead. Even though it doesn’t actually have a cast that seemed to work. I figured the 999 would just get dropped once the sim reached it’s set time limit, but it seems to not work that way.

Ah, yeah not having any cooldown on it would cause the AI healers to constantly spam it and fill up the simulation with tons of events, which is probably why it was so slow.