I get advice from Wow to Disable Aksmrrobot because of bugs?

Hi there,

After switching gear talents using AskMRRobot functionality things seem to go wrong. E.g., my tlaents suddely show that I have 5 points left to put into my talent tree. When I go flying with my drake, I get a message to disable AskMrRobot because of to many errors.

Anyone else has this behaviour ar well?

What is the error? We recently added some new functionality for changing talents – it may be that it is failing if you e.g. change gear sets while flying? The new Bizzard APIs for changing talents via addons are not very good unfortunately. We may have to disable it if people keeping having trouble with it.

When I start things up it looks like this:

Then I use AskMrRobot and click on the same spec I already am in and then is does:

The other error I see is just the error Wow gives when an add-on makens to much errors. If I see it I will copy it for you. But ofcourse it is not happening atm :frowning:

I do not have another spec that has less point. I only got =>


And when I restart it is back to normal. The 0/0 point left screen.

Hello same here. After using AskMRRobot I have to disable client addon to be able to fly. I didn’t see any error just suggestion to disable addon and if I chose to ignore it suggest every time I try to fly. I just came to open this question and I run into this that someone else has the same problem.

The talent issue is most likely because you haven’t set the loadout on the website correctly. I was having the issue of the addon wanting to swap talents when I changed specs until I made sure both my loadout on the website and in-game matched. You would think that when you first paste in an import it would have the talents all selected as per in-game but it was not the case for me. The first time I tried it after the new features were added. The loadout was there but not associated with the spec on the website.

Most likely you haven’t been keeping your talents updated for your Best in Bags setups as you level. We do not modify your setup talents because you could have multiple setups for a spec… and there’s no way to know which one you would want to update. (It has been like this for at least 3 expansions.)

We’re working on some more talent features to try and improve on things. I’m having a lot of difficulty with the talent swapping feature of the in-game addon in general… it kind of works… sometimes. I cannot reproduce the errors with flying though… I tried a few things with no luck.

I am not quite sure what you mean. But I have imported both specs again, when I was level 70. The weird thing is, as said. after a reload or a restart from WoW it shows o/0 again. Also, I do not miss any talent, it only shows I miss a talent when I use AskMrRobot. It does not do this when I manually change talents.

You probably haven’t updated your talents for you Best in Bags setups.

I did an update early tonight that will show you a message when your setup has different talents than what you last used in-game for that spec. There is also a button on the talent editor to set your talents to the last talents we imported.

Great, thank you for yor help. Cheers!