Item level of Vyrtha's Dredglaive

The item level of Vyrtha’s Dredglaive reads as 98 in the AMR optimizer, but ingame it is 140.

I would need a snapshot of your character to troubleshoot this – there are lots of different versions of the same items. Below are instructions on how to make a snapshot:

thanks so much for how to do this:)
here is my snapshot id 98de62d9cf344efabce82ee58d6718e4

my issue is the weapon item level in-game is 140, but in the AMR its level 98.

As far as I can tell, those items are being processed correctly… the raw data from the game says that you obtained those weapons when you were level 51, which would cause them to scale to item level 98. To be item level 140, you would have had to obtain them when you were level 58.

It’s possible that you need to refresh your addon data, and get the latest version of the addon (v102 as of this post). Once you have the latest version of the addon, do the following:

Let me know if that resolves the issue.

I think what’s happening is to do with scaling of BoE’s & treasures - esp.this Warglaive; my VDH has 4 of them waiting to be equipped - with the level they’re looted at, too… BoP’s don’t seem to get the same issue, though.

I have a similar example with a Polearm my L55 Warrior picked up just before I typed this; AMR on the site only shows the item as iL95:

… when in my bag it shows as iL113:

If a Snapshot will help then I offer: e327eb1ec07344eb906324ce517f1bb4

Yeah that’s weird… I’ll have to look into it some more – maybe there is a hotfixed item level curve not showing up in the game data available to me.

thanks again so much for your reply. It makes sense that the glaives should be level 98 as my toon was level 51, but I think I got them BOE on other toons and I think I had them in our guild bank. I thought yay! I’ll give them to the demon hunter when I level her. But now I’m thinking I couldn’t have used them at level 51 if they are level 140? but they clearly are, and I clearly did:) The in-game data can’t lie can it? It shows them as an improvement when I mouse over them with the shift key pressed.

I did as you suggested. I downloaded and installed the latest AMR addon from curseforge. I also activated the tank spec, even though i don’t use it, and then back to havoc. I opened the bank with the AMR closed, and then opened it and exported. I reoptimized again but the mr. robot website still sees them as level 98 not 140. I didn’t press UNLOCK ALL because I never locked anything. Any other good ideas?

File any solution to this under “Soon™…”; it may not be a simple one to get done, but I have confidence that one will be found.

One thing that would help for troubleshooting this further would be a copy of your AskMrRobot.lua settings file. It is saved in a folder like this on your computer:

C:\Program Files (x86)\World of Warcraft_retail_\WTF\Account\YOURACCOUNT\SavedVariables

If you could send me the AskMrRobot.lua file in that folder, I might be able to figure out if there is another piece of information tied to the item that is being used to adjust its item level.

The easiest way to get me a file like that would be to click on my name at the top of this post and message it to me. It should allow you to attach the file by dragging it from windows explorer and dropping it in the body of your message when you are composing it.

I found the file you asked for, but when i tried to paste into a message to you, it wouldn’t allow the .lua extension. Is there another way I can get the file to you?

Try copying the contents of it into a text file (with .txt extension), then send that to me. You can open the .lua file with any text editor, such as notepad.

Well i got the file copied to a .txt file, but when i try to message it to you i get “502” error.

Got any other ideas?

and thanks again so much for trying to solve this:) I am a casual player and mr. robot makes the small amounts of time i can play truly more enjoyable.

You could copy the contents of the file onto a site like pastebin, and then give me a link to the paste.

Tried Pastebin, too large of a file for it. I was able to copy it to a google doc, here’s the link

my name is Robin btw:). thanks so much for trying to solve this problem. I’ll say again Ask Mr. Robot is makes my game play so much more enjoyable.

Thanks – so now i can see the actual data for that weapon that the game is providing. As far as I can tell, that item does indeed indicate that it dropped or was otherwise obtained when your character was level 51… I’m not sure why it is showing stats for a drop at level 58…

Your cloak, Glitterwing Greatcloak, does that show the proper stats? This game data indicates it dropped when you were level 57 and so it should scale to that level instead of your current player level.

I’m wondering if this is something special to this particular item… because as far as I can tell… the game is just ignoring the drop level for some reason on this item only.

My DH - as I mentioned above - now has FIVE of this same Warglaive & all have been looted at various levels, but in game they all show as iL140. They are a BoE Treasure item from Revendreth & I think the level they are looted at determines what level they can be equipped at; I have two in my Bank that I cannot equip until L58 (just hit L55).

Snapshot ID (for said Demon Hunter) as of posting this message:

That said, AMR shows the two I have equipped as iL104 & the newest one that my DH looted @ L54 as iL116.

In support of my posts:


Those five images are for each item as shown in the bag they’re in:
Equipped Equipped
Fresh Looted
Looted by higher level characters than L55 that my DH is now (x2)

seems like it is except isn’t eighjan saying their DH Can’t equip it until a higher level? What a conundrum. I hope you solve it, but as for me, my DH is now 60 and have weapons above 140:)

thanks so much again


For now I guess I’ll just make this particular item always ilvl140… very weird!

The more “green” BoE’s I see as potential upgrades, the more I think that AMR needs to remove them from optimisation if how they work in-game has fundamentally changed; in-game data is not being recognised/acknowledged.

Since Shadowlands, the way that random loot BoE’s have been designed to scale is totally at odds with any system that WoW has seen before; since I use AMR to confirm how much of an upgrade BoE’s could be, I don’t think it’s going to be practical… unless an optimiser update is in the works.

By the time most characters get to L60, the quantity of BoE’s that are available is too limited to even make those items workable within the optimiser, either.