Junk List does not disenchant items

I have enchanting and when I click an item it’s removed from the list and nothing else happens. No disenchant, no error.

Which version of the addon do you have? I thought that I fixed this issue… wonder if it has come back somehow.

Not working here too. When i click any item it only disappears from the list and nothing else happens. Using version 120.

1 Like

I have version 120. For what it’s worth, it hasn’t been working for me at all since launch.

I’ll try messing around with it again… as far as I know, there isn’t really a way to make an addon initiate a disenchant directly – you have to hack around it by calling a macro from code. That part broke with 10.0… then I found some weird thing that seemed to make it work again… but now it has stopped…

I’ll have to hunt around the internet for a bit to see if anyone has figured out a way to do it.

1 Like

this might be what you are looking for. haven’t looked into your workaround, but dragonflight click binds needs this btn:RegisterForClicks(“AnyUp, AnyDown”)

Yeah that’s what made it stop in the first place, and I added that call to register for AnyUp and AnyDown, and then it started working again. But apparently something else has caused it to break since that change… still on my list to test it out, the holidays have slowed things down a bit.

So I just tried this on a character, and I was able to disenchant the item from the junk list… but it brings up the new “loot window” for disenchanting, sometimes behind another window. I’ll look into if there is a way to auto-loot the disenchanting results. I’m sure there is, just a matter of finding it…

I tried it again, this time without any other addons, and still no disenchant. The item just disappears from the list, nothing else. Tried right-click, as well as key mods, no dice. I tried casting DE directly and then clicking on the item in the list, and that didn’t work either.

This is with the most recent version on Curse (v120)

Strange… and you’re sure it is an item that can be disenchanted? I still need to add checks for that… and indicate which can be disenchanted vs. only vendored…

Yeah, I tested on a basic random green. Specifically “Isle Trapper’s Tunic of the Feverflare”.

Unless I can reproduce the issue I don’t know if I’ll be able to fix it unfortunately… all my tests have succeeded thus far.

I assume that you have tried all the usual things… like disabling all other addons to rule out a conflict, and double-checking that v120 is actually loading (shows at the bottom of the AMR addon UI when you open it).

I’ll still mess around with the behavior a little to try and smooth it out… who knows, maybe it will magically start working for you when I do that.

Unfortunately, this isn’t working for me either.

Yeah not sure… I might just have to disable the behavior entirely and have it only support vendoring items.

fyi VERSION 117, IT WORKS perfectly, might want to look into that code @yellowfive

There is only one difference between v117 and v120 with regards to this issue: the one that @aleksonfire mentioned a few posts back about adding RegisterForClicks(“AnyUp, AnyDown”).

If I remove that change (which is in v120), it stops working for me. If I add it back in, then disenchanting works fine.

I’m not sure why this change makes it work for some people, and not for others… or would seem to have the opposite effect for some users vs. others. At this point not sure what I can do about it unfortunately.

Did some research and I did this, " `/console ActionButtonUseKeyDown 1"
Doing this worked for Version 120
Wondering if DF changed this default to 0?

I’ll check that out – I have not changed that setting on my install, but I’ll see what it is set to and maybe that makes a difference!

I would like to avoid messing with that cvar on people since it does impact behavior, but maybe it’s a clue as to how to get around this issue. I do see a comment related to this setting and SecureActionButtonTemplate (which is used for initiating the disenchant).

The ActionButtonUseKeyDown is still 1 by default, but I somehow had it set to 0 as well. Changing it to 1 made the feature work.

I also tried changing frame:RegisterForClicks("AnyUp", "AnyDown") to frame:RegisterForClicks("LeftButtonUp", "LeftButtonDown"). This seems to work with both cvar settings.

Interesting – I’ll give that a try as well. Also going to see if I can attach the behavior to a different event and avoid the issue entirely.

I don’t know why Blizzard would make a user-editable setting related to only the action bar impact the behavior of a generic control available to addon authors… but such is WoW addon development.