Lua error on change spec and gear

getting thid error when switch spec and gear
balance druid
plz help

Getting the same error, on Paladin. Switching from Retri to Holy.

If you use more than one spec., please activate each spec. in game before exporting,. to make sure your Export string has all spec.'s working from the same start point… if the last time you Exported your off spec. was a few versions ago, that may be cached & need overwriting on either your local machine or the optimiser.

Thx for the quick replay. I tested your suggestion, activated all 3 Specs, exported the string, and reimported the string from the website to the game. Retri and Prot are working Holy still gave me this error.

Message: Interface\AddOns\AskMrRobot\Gear.lua:1101: Usage: LearnTalents(talentID1 [, talentID2, …])
Time: Fri Mar 26 18:12:01 2021
Count: 1
Stack: Interface\AddOns\AskMrRobot\Gear.lua:1101: Usage: LearnTalents(talentID1 [, talentID2, …])
[string “=[C]”]: in function LearnTalents' [string "@Interface\AddOns\AskMrRobot\Gear.lua"]:1101: in function setTalents’
[string “@Interface\AddOns\AskMrRobot\Gear.lua”]:1120: in function <Interface\AddOns\AskMrRobot\Gear.lua:1110>
[string “@Interface\AddOns\AskMrRobot\Gear.lua”]:1343: in function EquipGearSet' [string "@Interface\AddOns\AskMrRobot\Gear.lua"]:293: in function <Interface\AddOns\AskMrRobot\Gear.lua:292> [string "=[C]"]: ? [string "@Interface\AddOns\Ace3\AceGUI-3.0\AceGUI-3.0.lua"]:72: in function <Interface\AddOns\Ace3\AceGUI-3.0\AceGUI-3.0.lua:70> [string "@Interface\AddOns\Ace3\AceGUI-3.0\AceGUI-3.0.lua"]:306: in function Fire’
[string “@Interface\AddOns\AskMrRobot\ui\AmrUiButton.lua”]:25: in function <Interface\AddOns\AskMrRobot\ui\AmrUiButton.lua:22>


Are you using version 100 of the addon? In theory I put in a check that should avoid this error.

People were getting this error when their exported setup had no talents selected. Perhaps there’s another edge case causing this error though… could you press the “help” link next to the big Best in Bags section header on the website, then press Create Support Post, and copy the generated snapshot ID here? I want to see exactly which talents you have chosen for your setups.

Yep updated to v100 via Curse, before starting the game this morning.

Snapshot ID: 211e59d0f7ec448ea575e93b3b3f6903

Edit: I did some further testing. On my Monk switching between all Specs worked before exporting/mporting. After that I got the same Problem when switching to Brewmaster.
On my DH the same procedure produced no error.

Snapshot ID Monk: a18f8fb19b374a5e8bbe00d477129101

Same for my Paladin.

Yeah I guess that addon update didn’t fix the issue – you have no talents selected for some of your setups on both those characters. Choose some talents then re-optimize, that will fix the issue. We would highly recommend doing this anyway, as the optimizer tailors its suggestions to your chosen talents.

I’ll try something else to avoid this error when someone has no talents selected.

Both chars have all 3 Specs fully talented in game, shouldn’t it be detected automatically? I never had to manually choose talents on the page until now, they were always detected after exporting.

All my specs are talented, still get the error.

In the setup for best in bags however no talented seemed selected, after selecting there it worked.

Yes that is what I meant – you need to choose talents for your setup on the website.

Version 101 (and higher) of the addon has an option to disable the behavior that automatically chooses talents (and soulbind) as well. It is on the options tab of the in-game addon.