Misc bugs & feature request

Bug 1:
When using the default profiles, specifically the Demo Warlock, it gets loaded in with boots that are from MoP PvP era at 384, it is impossible to obtain these items at this item level. It has bracers, belt and boots with this issue.

Bug 2:
When browsing gear in the simulation for a single sim, it seems to get “stuck” on a specific slots items. I can’t browse any items besides rings after I click on them. No JS error happens.

Feature Request:
It would be super cool if you could bring back “Simulate Setup” for BiS cases :slight_smile:

Those items are just some junk from beta that got past the filters. We’ll update the generic characters at some point.

I can’t reproduce the error with the item list getting stuck… there must be some specific sequence of events leading to it. Tried what was in your video, no dice…

I tried this again starting from the top, I got some javascript errors this time


and here’s a gif start to finish


The bug happens when you click on a slot twice. If I click on “Weapon -> Offhand -> Weapon” Weapon doesn’t show up anymore.

Edit - Don’t mind the artifacting, that’s just a quirk of the program I’m using to record gifs :upside_down_face:
Edit 2 - Uploaded better quaility with no artifacting
Edit 3 - I definitely know it’s not one of my chrome addons. I tried it with incognito mode and it still didn’t work.

I had someone run into this at work when we were talking about it, and I recreated it at home as well.

He was on Chrome, I am on Firefox. All I did was load the premade Frost Mage.

Edit: Can confirm, this happens when you click any slot, click off, and then click back on.

Try it with the latest version of the site, I think it is fixed – can’t reproduce it anymore at least.

Seems good now :slight_smile:

Yeah looks good to me.