My itens in Great Vault are not showing in the Upgrade Finder

ID Snapshot: 5abee9165e444cd2872ff3926c5c6911

I have 3 itens in the Great Vault but when I export my character in the website it says I don’t have any. Anyone with the same problem?

Having this same issue. Tried reloading the Vault a few times, and then re-importing the generated addon export. Still doesn’t show me anything in the Upgrade finder Great Vault section.

In-game addon version has to be 0.96 or greater for it to work.


Huh, weird, the curseforge version of the addon is v0.95 and considered up to date. Thanks for the info.

You can download the addon directly from our website for now


I did this, but now the server is lagging at not loading the Great Vault, so I am just waiting for that. Appreciate the help.

For some reason version 96 didn’t make it to curseforge (even though I pushed the update as usual). I have manually uploaded it to curseforge – could take a bit for it to be available though.

I’ll have to contact them and see why my normal method of updating no longer works…

1 Like