New version duplicating setups, not updating with latest export from web site

I have a toon I play only as a windwalker monk. Send to add-on and import keeps creating more and more values in the dropdown that all say “Windwalker” (I have 5 of them now). Worse, none of them have the gear as it should have been exported from the web site. They don’t include a new ring I got.

it appears to be broken for me as well
the gear on the left does not match the equipped gear
and the gear on the right is likely what amr’s suggestion on what should be equipped.

I have downloaded from this web site the new version (v65) and manually installed it
thought twitch was doing it incorrectly (game was closed when i installed it, not sure if that still matters)

cheers, al

I captured some screenshots to illustrate the issue. Unfortunately I’m only allowed to upload a single image so I had to get creative to stitch them together. I hope this is clear.

When I import from the addon, I periodically have some slots read as not having any item equipped. The first time it was no Heart of Azeroth necklace, the second time it was no Shoulders or Chest piece.

That’s strange… I’ll see if I can figure out how to reproduce that.

In the meantime, you could try resetting the addon. An easy way is to use the twitch app to delete the addon and choose the option to also delete any related addon settings. Then reinstall the addon. Important! Make sure to do all this will the game is closed. Then fire up the game, activate each of your specs once, open your bank once, export to the website, then import back into the addon. Let me know if that resolves the issue.

1 Like

I think your issue is unrelated to the original poster’s. Usually that happens if you destroy an item in some way (sell it, scrap it, vendor it, or move it to void storage where the addon can’t see it). When your heart of azeroth upgrades, it kind of does the same thing – the old version of your neck is gone and now you have a new one.

You can usually resolve this issue by simply activating each of your specs once in-game, then export again.

I am also experiencing the same issue as OP. I tried downloading the latest add-on directly from the website but still no joy.

  1. I copy the exported string from the Export tab (in game)
  2. I paste it to the website
  3. I optimize on the website
  4. I export to addon on the website
  5. I import in the Gear tab

I have tons (15?) of “Vengeance” specs listed in the dropdown at the top of the Gear tab.

My gear is not changing though. None of the specs listed in the drop down match the gear listed on the website.

If I rename the Setup on the website and re-optimize then export again I see this new name at the bottom of the dropdown list but the gear does not change.

I’m still trying to figure out what would cause this for some people… perhaps you could try completely resetting your addon, and see if it fixes the issue?

You can do that as follows:

  1. Completely exit World of Warcraft.

  2. Go to your folder where WoW is installed, and find the AskMrRobot.lua and AskMrRobot.lua.bak files in your WTF folder – delete them. For example, they are usually at a path like:

C:\Program Files (x86)\World of Warcraft\WTF\Account\[your account name]\SavedVariables\AskMrRobot.lua

  1. Start WoW again, and do the steps to reinitialize your gear data: activate each spec once, and open your bank for a second or two.

Let me know if this issue with duplicated sets continues to happen after doing that.

I think that I know what is causing this for some people – I’ll work on a fix for it. I think it only happens if you have just one Best in Bags setup on the website.

In the meantime, you can get around the issue by ensuring that you have at least two Best in Bags setups. An easy way to do this would be to simply activate one of your other specs on the website – it will auto-generate a setup for you. It doesn’t matter if you never intend to use this off spec setup. Just leave it for now, and when you import, it should get rid of all the duplicates.

Once I finish an update with a fix, you can then delete the extra setup if you don’t want it.

I updated the site and published version 66 of the addon, which should resolve this issue. It can take a couple hours for addon updates to make their way to the twitch app, in the meantime you can always get the latest directly from the addon web page:

YES! This totally fixed it. Thank you!