One character not loading correctly

I’m running a lot of characters. For some reason, one particular DK does not play well with the site.

If I’m looking at another character, and try to switch to her, the site still appears to be the old character. However, BiB will show the recommended items for the DK.

I can get the main display right by choosing her a second time. However, talents will still reflect the last other character viewed. Clicking the Edit Talents button shows an empty talent tree.

Snapshot: fae73ee28c5a4d6195c92c1ef8fd82bd


I have DKs in the site both higher and lower level; afaik only this one is having issues.

Th optimiser only works with data imported from the in-game add-on, not from Armoury updates (as they are unreliable &/or broken); the only time I would advise accessing a character in the optimiser is once the most current data has been imported.
The one thing I would suggest is to Ctrl+F5 on the AMR optimiser page, to clearout any erroneous data.

The snapshot you provided shows the DK in question as it should, but switching to your other characters from there is something only you can do.

Hi! Thanks for stopping in. All my characters are imported from the in-game addon. I think I’ll have to tell this story in screenshots if the snapshot shows no problems.

Disclaimer: I was using F5, not Ctrl-F5, so I’ll use the latter now to see if it helps.

I just deleted Yesenna’s profile (the DK at issue) from the site. I logged out, used Ctrl-F5 and logged back in. And now I’m starting from my main character, and attempting to import Yesenna from the add-on.

Okay, my main’s druid talents are showing. So let’s Ctrl-F5 again.

For some reason no talents are being imported on this character, although I have profiles of imported DKs both higher and lower level that show properly. If I click Edit Talents and try to update from the last import, nothing happens. The talent tree remains empty.

Now I use the pulldown to switch back to my druid. AMR changes to her just fine. I use the pulldown and click Yesenna, and the page still shows the druid. I click Find Best in Bags and get similar to what I showed in my first post. Banner shows the last character viewed, BiB shows Yesenna.

I click Yesenna again from the pull-down and end up back where I was in the first picture of this post: a DK with druid talents.

For comparison, Yesenna is lvl 17, and this is how a different lvl 10 DK loads:

Deleting Yesenna’s profile doesn’t clear her preferences, so I assume I can’t do anything on my end to completely wipe the profile clean to start over, and I have no idea if that would even fix anything.

To clarify, because I missed this… you’re saying my provided snapshot shows everything correctly? Including Yesenna’s talents?

Ohh… I see what you mean - Gear gets optimised but no Talents are shown; potentially none were Imported…?

Even just for sanity’s sake, try reimporting DK aften opening their Bank & Talent screen…

That’s weird, almost seems like a javascript error is preventing the page from switching between characters fully.

In the screenshot where you imported your DK and it showed druid talents… you had just refreshed the web page and had not previously loaded a druid into the page? Could you give me the addon string that you copy into the website for that case? I’ll try to reproduce the behavior.


Nope, didn’t change anything. DK with other-class talents.

I… hmm. I don’t know how to make AMR not load a character by default when I go to optimize. To be clear, the talents shown/upper banner are those of whatever character I was last working with. In this case I chose my main, a druid.

Best I can think of… I loaded Yesenna and Ctrl-F5’d. Leaves me with Yesenna and no talents. Reimport the addon string, same thing, no talents.

Addon string: $125;US;Earthen Ring;Yesenna;Singularity;10;2;17;12:1,4:4;3;.s1;1;;.s2;2;;.s3;3;010000000000000000000000000011000000001100000000000000000000000000000000000000001111000000;.q3;38666s9v12b6691!BCC54FC4A;1s10v2b0!BCC595CD2;1s6v-2b0!BCC567EEB;2s8v1b0!BCC56CEF9;83590s15b2663!BE2B58C4A;3s1b0!BE2B58518;1s7b0!BE2B58DBA;97s13b0!BE2B5A088;0s14b0!BE2B5A060;4s16b0e3368!BE2B5978F;7s3b0!BE2B5879F;15s5b0!BE2B58CCD;142s11b0!BE2B5991A;139s2b0!BE2B59978;5505s12b0!BE2B59856;.tal;.inv;6948!BCC5E4715;115297b9354!BE2B585B1;6b0!BE2B58E2E;15b0!BE2B58C24;83b0e3368!BE2B58F1F;6b0!BE2B5871D;26b0!BE2B58D28;7b0!BE2B586B5;274b0!BE2B59AE4;1b0!BE2B59AAB;4b0!BE2B59945;5505b0!BE2B598EE;146b0!BE2B5A01D;24812b0!BE2B59A16;46556b0!BE2B5A0C2;.gv$

Yeah looks like a javascript error is happening, which stops the page from loading (so it isn’t fully switching from the previous character to the imported character). I’ll look into what’s causing the error.

Does that also explain why it doesn’t seem to be loading talents even when force-reloaded? Is that just a visual thing?

Also, if you have to kick her off my account, that’s fine. I’ve done very little to her profile and she’d be easily rebuilt.

When it hits the javascript error, the page essentially stops loading. You would need to refresh the web page after that, or else you’ll get unpredictable results.

I tried it on my dev system and don’t seem to be getting the error… we’re doing an update tonight so hopefully that resolves the issue.

Okay, I’ll try again on her tomorrow.


So I did an update, and I’m still getting the error on the live site, but not on my dev site… not sure what’s going on. I tried exporting my own unholy DK, and it’s reading the talents just fine…

I’ll see if I can figure out what’s different… you could try going in-game and changing some talents and exporting again, see if it clears up the issue or not.

Yep, as I showed in the screenshots I have other DKs (all Unholy) loading fine. It’s just… this… one.

Operation Talent Switcheroo: Failed. Still no talent import.

FWIW I also tried firing up MS Edge (Chrome is my default) which had no memory of the site. Came up the same, no talent import.

I’m still trying to figure out why this works on my dev site but not the live site… I have checked everything… the error seems to indicate that the live site is using a different version of the talent data, but I ruled that out by manually confirming that dev and live are using the exact same data.

I have one other thing to try later tonight to get some more debugging info, we’ll see if that helps.

One thing you could try… activate your blood and frost specs on that character in-game and choose some talents (doesn’t matter which talents), then switch back to unholy and export. Does that help? If not could you post that export string here too?

Do you want me to set up profiles for each spec to see if any import?

Wait… something in that fixed it.

Process: I opened Blood and picked some talents, then opened Frost and did the same. I imported on Frost (oops), re-read your post and switched back to Unholy. Imported again from Unholy and hit BiB.

The site stuck me on Frost, and I couldn’t click on Unholy.

I then swapped to Blood, and imported from there. And bang… now all three work.

Export from Blood:

$125;US;Earthen Ring;Yesenna;Singularity;10;2;17;12:1,4:4;1;.s1;1;0000000000000000000000000000001001100000000011000000000000000000000000000000100000111000;.s2;2;00000100000000000000000000000000000000000001111000000000000000000000000000011110000000;.s3;3;010000000000000000000000000011000000001100000000000000000000000000000000000000001111000000;.q1;38666s9v12b6691!BCC54FC4A;1s10v2b0!BCC595CD2;1s6v-2b0!BCC567EEB;2s8v1b0!BCC56CEF9;83590s15b2663!BE2B58C4A;3s1b0!BE2B58518;1s7b0!BE2B58DBA;97s13b0!BE2B5A088;0s14b0!BE2B5A060;4s16b0e3368!BE2B5978F;7s3b0!BE2B5879F;15s5b0!BE2B58CCD;142s11b0!BE2B5991A;139s2b0!BE2B59978;5505s12b0!BE2B59856;.q2;38666s9v12b6691!BCC54FC4A;1s10v2b0!BCC595CD2;1s6v-2b0!BCC567EEB;2s8v1b0!BCC56CEF9;83590s15b2663!BE2B58C4A;3s1b0!BE2B58518;1s7b0!BE2B58DBA;97s13b0!BE2B5A088;0s14b0!BE2B5A060;4s16b0e3368!BE2B5978F;7s3b0!BE2B5879F;15s5b0!BE2B58CCD;142s11b0!BE2B5991A;139s2b0!BE2B59978;5505s12b0!BE2B59856;.q3;38666s9v12b6691!BCC54FC4A;1s10v2b0!BCC595CD2;1s6v-2b0!BCC567EEB;2s8v1b0!BCC56CEF9;83590s15b2663!BE2B58C4A;3s1b0!BE2B58518;1s7b0!BE2B58DBA;97s13b0!BE2B5A088;0s14b0!BE2B5A060;4s16b0e3368!BE2B5978F;7s3b0!BE2B5879F;15s5b0!BE2B58CCD;142s11b0!BE2B5991A;139s2b0!BE2B59978;5505s12b0!BE2B59856;.tal;.inv;6948!BCC5E4715;115297b9354!BE2B585B1;6b0!BE2B58E2E;15b0!BE2B58C24;83b0e3368!BE2B58F1F;6b0!BE2B5871D;26b0!BE2B58D28;7b0!BE2B586B5;274b0!BE2B59AE4;1b0!BE2B59AAB;4b0!BE2B59945;5505b0!BE2B598EE;146b0!BE2B5A01D;24812b0!BE2B59A16;46556b0!BE2B5A0C2;.gv$

Yeah I’m still not 100% sure why it wouldn’t work with just Unholy… but glad we can at least get around it for now!