Priest: Discipline - Simulation incredibly slow / stuck at low percentages

I’m trying to simulate the healing loss when taking Grace instead of Evangelism for raid healing and how gear stats would change. But currently the simulation is not really working. It’s already running for 5+ hours and is still suck at under 10%. Is there any way to fix that?

Healing simulations are really slow. Sometimes the progress reporting gets behind. Just let it keep running and it will eventually finish.

I started a new simulation after you anwsered. It is currently stuck at 0 of 1915 runs. The app shows that it is running chunk 20 since pretty much the beginning. There is no visible progress now for at least 14 hours and the app is not using any of my pc’s ressources. I really think that’s a bug.
The app is version 371, with the current live build ( I’m using the Raid Healing Krosus Rotation and Raid Healing Krosus Boss/Script. No changes in the default settings.The only thing different compared to the default strategie are talents. I’m using Shield Discipline, Sanctuary and Grace instead of Mindbender, Shadow Convenant and Evangelism.
If it helps, I could post the id of the report. Perhaps it’s a software problem on my side.

Yeah post the link to the report. We’ll take a look - I can run discipline strategies, so, not sure off the top of my head why this problem might be happening.

I will try running this on my computer later tonight, just to rule out an error in the actual simulator.

Otherwise… it’s going to be pretty hard to figure out what the problem is. What performance mode are you running your client in?

Currently I’m switching depending on my use of the pc. Most of the time it’s running in max mode with no global network. When I’m gaming/working it’s running in background mode.
It might be possible that the simulation might have run into a 24h disconnect. But as far as I understood the synergy between app/site that shouldn’t cause any issues.
Perhaps it’s some weird synergy between gear and talents that causes the simulator to stop working. Or I’m just cursed with some other issue XD

I restarted the client as administrator and am currently running a new simulation. This one seems to be working for now. I will update if it keeps working/ finishes.

Simulation stopped working again. Started another one on my laptop and that one finished properly… Guess the issue is on my side. No idea what is wrong.

I have been having this exact same issue. I run simulations and they get stuck on a chunk. So I thought I would “brute force” it to see if I could get it to completes. I created two 16 processors instances on Azure, used my gaming desktop (Core i7) and a entertainment PC (Core i5). This simulation ran for nearly 12 hours with 42 processors working on it. I had to restart the clients on multiple occasions. Finally, I got down to the last 10 steps of the simulation on one of the 16 core Azure instances. However, I couldn’t get a chicken dinner. It was just stuck. The processors all ran at nearly 100% for hours. Then… the client got updated and I lost my ability to restart it. I had to stop it because I think I chewed through about $50 in two days running this on Azure.

I am currently trying to run a new simulation using the latest client. Seems to still be getting stuck. Lets see if I can get it to finish though.

BTW: I have reported this to AskMrRobot during when I first got the problem, then after I tried the Azure brute force approach.

Yeah shouldn’t take that long – if you have a link to the report that is getting stuck, we can take a look.

It can sometimes take a while to track down gearing strategy issues like this though, because it’s probably a particular setup out of thousands that is causing the problem. So definitely let us know if you notice this kind of slowness on a single run also.

I`m running a Sim for a Mistweaver monk and am shocked that 12+ hrs later its still only 76%, my avg time for dps is 40 mins, is this what I should be expecting for healers in general.?

Which rotation/boss script are you using? If it’s the raid healing one, that could be an expected difference. Mythic+ healing sims are fast. Raid sims have to track 19 other allies besides you and AI healers as well, so they take much, much longer.

Krosus hc raid healing, the sim has now reached 99% and seems to be stuck,

I have seen this message for over a hr now Running simulation 26f18dd5dc644c2698781c58d8bb41e5, chunk 8 and the remaining time was ment to be 8 mins

Not sure if it is related, but our next update does fix a bug that was getting Discipline simulations stuck in rare cases. Not sure if it would also impact certain setups for Mistweaver or not.