Relics missing from exports

The AMR is not picking up relics reliably at all. There’s been an awful lot of times lately when I’ve been in the middle of switching sets to update the equipment set UI, and realized AMR is showing no relics in this or that weapon. So I have to stop, open all the weapons and do it all again.

I was playing my warrior tonight… I’m pretty sure I’d opened my weapon UIs several times over the course of the evening, but not sure if I had during this particular play session. I ran AMR earlier after completing the first order hall campaign and choosing where to place two new relics.

It’s been happening on my main as well.

I just reproduced it. I logged out to try to clear some clinging world quests. That failed, but I ran AMR to see if anything happened with it. It showed my relics correctly. I then quit the game still trying to get rid of those wq’s… restarted the game, stupid wq’s still there. Exported AMR again, and my relics are messed up.

After restarting the game:
$51;US;Silvermoon;Baaljagg;Six Minutes To Release;12;1;110;13:715,7:742,15:700,12:729,1:767,14:715;3;.s1;34;1312122;1136,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,205,37,321;1,1,1,1,1,1,1,4,3,3,4,3,3,4,3,3,1,1,1;,;.s2;35;2333333;980,1,1,2,1,1,1,1,1,1,1,1,1,1,1,1,361,37,321;1,1,1,1,1,1,1,3,4,3,4,3,3,3,3,3,1,1,1;141261b1482b1824b3527,140079b1482b1825b3527,;.s3;36;3233312;91,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1252,37,226,1,1,93;1,1,1,1,4,3,1,3,3,3,3,3,1,1,4,3,1,1,4,1,1,1;,132800b664b1601b1809,142059;.q1;117376s15v110b3596;4115s13v-5b-2932;311s12;7108s16b86x132340y713;5610s9b707b369;4299s14v-3b-1162;282s2b823b338b1702;586s6b-143b2;318s1;19s11b-1914b203b150;1554s8b-328;5653s5b150b40b1649b238;9s10b-3533b1626b35b1635b237;8s7b-1922b32b1652b238;4s3b-1932b43b1843b46;.q2;117376s15v110b3596;4115s14v-5b-2932;311s11;7106s16b87x141261y-1182;5645s17;4266s13v-3b-87;282s2b823b338b1702;586s6b-143b2;1s9b-5b5;336s12b-1914b203b150;1554s8b-328;5653s5b155b53b1631b238;9s10b-3533b1626b35b1635b237;4s1b-1922b26b1658b238;4s7b-1922b32b1652b238;4s3b-1932b43b1843b46;.q3;117376s15v110b3596;4115s13v-5b-2932;69s12v4b103b966;6728s16;1s17b-981x132781y19z9259;10530s14v-7b-88;868s6b2720b2;1s9b-5b5;336s11b-1914b203b150;1554s8b-328;5198s2b-25b353b1702;455s5b-1875b53b1631b238;9s10b-3533b1626b35b1635b237;4s1b-1922b26b1658b238;4s7b-1922b32b1652b238;4s3b-1932b43b1843b46;.r;_;.inv;5218;20760;7842;4527;2129;5102;1;6447;12373;6684;279;272;14509;1256;5348;11583;3927;819;177;1307;3121;2372;860;3;1449;2580;335b1507b318b1512;54;0;1;1;14;299v106b-2673;153;2116;1;205;313;63;3853;160;395b87x141261y-1182;2b-1x-7739y713;409v3b-86;2491;116;273;5;2316b793b369;1830;1761;16;115;1;724;134b-339b338b1702;580b-144b3;3b-5b4;102;6;203;10;187;741;672;5626b-1738b40b1649b238;322;3$

Corrected, after opening the weapon UIs yet again:
$51;US;Silvermoon;Baaljagg;Six Minutes To Release;12;1;110;13:715,7:742,15:700,12:729,1:767,14:715;3;.s1;34;1312122;1136,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,205,37,321;1,1,1,1,1,1,1,4,3,3,4,3,3,4,3,3,1,1,1;132340b1605b1793b1809,133053b1555b1793b1809,;.s2;35;2333333;980,1,1,2,1,1,1,1,1,1,1,1,1,1,1,1,361,37,321;1,1,1,1,1,1,1,3,4,3,4,3,3,3,3,3,1,1,1;141261b1482b1824b3527,140079b1482b1825b3527,;.s3;36;3233312;91,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1252,37,226,1,1,93;1,1,1,1,4,3,1,3,3,3,3,3,1,1,4,3,1,1,4,1,1,1;132781b767b1597b1809,132800b664b1601b1809,142059;.q1;117376s15v110b3596;4115s13v-5b-2932;311s12;7108s16b86x132340y713;5610s9b707b369;4299s14v-3b-1162;282s2b823b338b1702;586s6b-143b2;318s1;19s11b-1914b203b150;1554s8b-328;5653s5b150b40b1649b238;9s10b-3533b1626b35b1635b237;8s7b-1922b32b1652b238;4s3b-1932b43b1843b46;.q2;117376s15v110b3596;4115s14v-5b-2932;311s11;7106s16b87x141261y-1182;5645s17;4266s13v-3b-87;282s2b823b338b1702;586s6b-143b2;1s9b-5b5;336s12b-1914b203b150;1554s8b-328;5653s5b155b53b1631b238;9s10b-3533b1626b35b1635b237;4s1b-1922b26b1658b238;4s7b-1922b32b1652b238;4s3b-1932b43b1843b46;.q3;117376s15v110b3596;4115s13v-5b-2932;69s12v4b103b966;6728s16;1s17b-981x132781y19z9259;10530s14v-7b-88;868s6b2720b2;1s9b-5b5;336s11b-1914b203b150;1554s8b-328;5198s2b-25b353b1702;455s5b-1875b53b1631b238;9s10b-3533b1626b35b1635b237;4s1b-1922b26b1658b238;4s7b-1922b32b1652b238;4s3b-1932b43b1843b46;.r;_;.inv;5218;20760;7842;4527;2129;5102;1;6447;12373;6684;279;272;14509;1256;5348;11583;3927;819;177;1307;3121;2372;860;3;1449;2580;335b1507b318b1512;54;0;1;1;14;299v106b-2673;153;2116;1;205;313;63;3853;160;395b87x141261y-1182;2b-1x-7739y713;409v3b-86;2491;116;273;5;2316b793b369;1830;1761;16;115;1;724;134b-339b338b1702;580b-144b3;3b-5b4;102;6;203;10;187;741;672;5626b-1738b40b1649b238;322;3$

Do you have any other addons that read relic data? I’m wondering if another addon is conflicting somehow.

Well, I just added one (RelicHelper, yesterday) but this was going on previously. Um. I’m not aware of any others that specifically tap the relics, but I’ll list some artifact-related suspects.

Broker Artifact (tracks AP and traits, doesn’t touch relics that I know of)
Personal Loot Helper

None of those are new since the problem started, but perhaps some update changed something. Maybe Ovale? But I don’t think Ovale is that sophisticated.

This has been going on probably a couple of weeks, but I was loathe to post until I could nail it down at least a little.

Yeah… hard to say, one of those addons could be e.g. flashing the artifact UI and triggering multiple updates of the artifact data, and maybe closing before our addon gets a chance to finish reading it.

I plan to switch to a library that someone made for reading artifact data soonish… hopefully that would take care of any sort of difficult-to-track-down incompatibility with another addon. Unfortunately WoW’s addon design makes it really easy for addons to interfere with each other.

THis happens to me constantly, the work around I have found is to open up the artifact tab for each artifact the one equipped and also in bags just right click on it. THat will update your data then hit the Mr Robot export, your relic data will be there. Lots of addons read relic data now a days. Some addons need this data to determine what state to be in. ie… Hekili being one.

Do you think that you could try e.g. disabling your other addons, load up the game and open each of your artifacts once, then log out or reload your UI, and see if the AMR addon still remembers your relics on the next export? Would be nice to try and narrow down the specific conflict so that I can be sure to address it when we do the next addon update.

It’s not something that always happens, I suspect it is something that happens on Specialization swap, one of my addons “Hekili” Dos do a check to see what is and isn’t talented on my weapon to decide on best APL. It could be Hekili doing it’s check of weapon talents and your addon trying to read at the same time.

Sometimes it will remember only the active profiles relics, at other times it will only see relics you have in your bags and recommend you equip those since It thinks you don’t have those relics.This addon does an extensive check of your talents/equiped Gear/weapon talents even the presence of pre pots in your bags. Hekili is a nice guy to talk to he is always on the shaman discord, I think this addon goes by another name in some other circles “Ovale Spell prioroty” Hekili is more tuned for Ele and encahnce shamans.

I think I found a line of investigation. I’ve had a problem with notably slow loading lately. On a reload, I opened up my weapons to refresh the relics… and one of them showed no relics in the UI until that slow loading was done. Once everything caught up, the relics showed up.

Grimmshadows, have you also been experiencing long load times? Like, you get into the game, but not everything is fully functional for a bit? One of my most obvious symptoms has been mounting immediately on appearing, and my character just flat goes invisible and the screen PoV won’t move. A few seconds later, my screen catches up to all the movement I’ve done in the meantime.