Retail: Addon icon disappeared

I have updated to v.83. The addon doesn’t show. It already didn’t show before the update, today.

Addon is listed in “addons”. No command works.

Have you tried disabling all other addons? That’s the first step usually when trying to diagnose issues like this.

Completely exit WoW, start it again, disable all addons except AskMrRobot, then log in, and run

/amr reset

If that doesn’t work, then there might be an error with the addon in your particular case. The best way to get more information would be to install the two addons BugGrabber and BugSack. This will create a minimap icon that captures error information in other addons. Try that and see if you are getting an error in the AskMrRobot addon, and paste the details here.

Yes, disabled all addons, logged-back in, ran /amr reset and saw nothing.

I can’t see those addons in Twitch. For the record, I can’t also see Ask Mr Robot addon in Classic on Twitch.

Also, I checked on other characters, and problem is the same.

Our addon is not available for Classic yet – it’s just a beta test for now.

Addon still doesn’t work in retail. Any update or should I end my subscription?

For the record, the addon is installed, because it tells me that “no saved gear could be found for the current spec.”

I think that we need to just start “from the beginning” to make sure that we’re on the same page.

  1. Completely exit World of Warcraft
  2. Ensure that you have the latest version of the AskMrRobot addon installed (v83 as of this post)
  3. Start up WoW, and disable all addons except the AskMrRobot addon
  4. Log in on your character

At this point, do you see a minimap icon for the AskMrRobot addon? If not, then try typing the following in your chat window, then press Enter:

/amr reset

Then for good measure, reload your UI (you can use a slash command for that, or simply log out and back in to your character again.

Do you see the minimap icon now, and can you open the AskMrRobot addon in-game?

If so, we can continue from there and try to figure out what else might be causing an issue for you.

  1. Done.
  2. v83
  3. Done.
  4. Done.
    Did /amr reset
    Reloaded ui.
    Don’t see the minimap icon.
    Can’t open the AskMrRobot addon.
    Still get the : No gear set could be found… message.

When do you get this message, and where do you see it? Do you see it immediately upon logging in, or after taking some action? Is the message in the chat window? What is the exact, full text of the message?

I get the message when I change specs, for example frost to blood. It is displayed in chat.

The exact text message is: AskMrRobot: No saved gear could be found for the current spec.

The message is sent twice.

At this point I think you need to try and delete all saved settings for the addon. You can do this with the twitch app, or you can do it manually:

  1. Completely exit WoW.
  2. Locate your AskMrRobot.lua settings file, in a location similar to this:
    C:\Program Files (x86)\World of Warcraft\_retail_\WTF\Account\MYACCOUNT\SavedVariables\AskMrRobot.lua
  3. Delete the file.
  4. There may also be a file right next to it called AskMrRobot.lua.bak – delete that too.

Then try running the addon again, with all other addons disabled. Let’s see if that brings it back for you.

Thanks. I located the file (actually two, as there is a .bak as well). How do I delete it on Windows 10, please?

Also, I created a new character, and the AMR icon shows on that character. What I just noticed is missing on the older characters is the drop-down menu that was above the minimap. That’s where I’d activate AMR when needed…

OK, I believe I fixed it, by uninstalling all addons, and changing the name of the Cache, Interface, and WTF folders.
I reinstalled all the addons, and it still didn’t work. I had to uninstall AskMrRobot one more time, and then reinstall it. That did the trick… so far. Thanks for your help.

Glad you got it working! Yeah there must have been a bad setting that kept coming back… they can be pretty “sticky” sometimes.

1 Like